Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Almost everything is blocked where I am and I need to use a transparent proxy to access anything. I tried using Tor (online anonymity software) but it doesn't work for all the system applications.

I also tried putting 127.0.0.1:8118 in system's proxy settings and applied it system-wide. But It didn't help at all.

share|improve this question
1  
which version of tor you are using? current versions uses 9050 as socks port and 9051 as http port as i used a couple of weeks ago. –  sarowar Jul 22 '12 at 21:03

3 Answers 3

You may want to try these instructions on using Tor as a transparent proxy, as provided by the TOR-project itself.

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Léo Lam Jul 9 at 14:31

Tor provides proxy via both http and socks. So when you want to use it in proxy settings, you need to ensure that you're using correct proxy (http or socks). And check the port before use it.

So Check your tor settings and set proxy accordingly.

You can also use proxy softwares like FreeCap.

share|improve this answer

All the above steps will make you crazy. I am going to share with you what I have chosen to and works perfectly.

  1. Install torsocks by going to Ubuntu Software Center and typing "tor" and select additional packages.

  2. After installation, go to System Settings... → Network → Network proxy and enter these settings: 127.0.0.1 and port 9050.

  3. Apply and restart.

  4. In all your browsers and apps choose to "Use System Proxy Settings".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.