Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem while using transmission. I don't know where it comes from because it doesn't occur every time.

Sometime while downloading a torrent, I cannot browse on the internet with a browser. Or if I can it is extremly slow.

I opened the correct port on my router. I limited the upload download to a reasonable amount (50/5, my upload is very bad). I don't not allow transmission to use PnP and NAT-PMP. And this doen't seem to be related to the download speed of a particular torrent: before limiting download I could download at 800ko/s and have no problem and sometime the problems occurs with download at 3ko/s.

Is anyone else having this problem?

I really don't understand, isn't opening the correct port and disabling plug n play suppose to make transmission not interfere with http?

share|improve this question
    
If it helps, it has always interfere with my connections. ANY connections. SSH, HHTP, FTP, etc.. If i open transmission am opening a can of whoop ass on my PC related to the internet connection. I normally just download ktorrent and use that one instead of transmission. First because of this, second because of the options. –  Luis Dec 8 '10 at 21:41
    
i can not say the difference related to why Transmission does that. I have checked with net command the amount of ports vs the amount ktorrent opens for the same torrents (Tested only 5 torrents). They were almost they same. But here is the weird part. Ktorrent can start almost immediately to download a torrent while transmission takes some time to start, like it was checking something first. And even though Transmission hogs the connection, ktorrent maintains a faster connection while still giving you a slight faster web surfing performance in comparison with transmission. –  Luis Dec 8 '10 at 21:42
    
NOTE: Tested changing amount of uploads, downloads, speed, etc.. Does not 1. Go to EDIT then select PREFERENCES. 2. Go to Speed TAB and limit to less than 20% of you connection. For me is 20KB/S. 3. Go to Network TAB and limit to 10 Peers per torrent or less. My test was with 8, 5 then 3. Maximun Peers Overall change it to 20 or just the same amount for 1 torrent. 4. Download just 1 TORRENT. Just 1. Wait 15 seconds. You can not use Firefox or anything else cause all the connection is sucked by Transmission. –  Luis Dec 8 '10 at 21:42
1  
Hello. I tried Stefano's solution because I want to keep only gnom apps. Then I did your test and it didn't slow Opera at all. Maybe that was the proble for me. However I also noticed that transmission never start downloads immediatly, this is not a big problem to me. If you learn more about those difference I'm still curious! Thank you. –  Noz Dec 8 '10 at 21:52

4 Answers 4

up vote 10 down vote accepted

The problem, in your case, is probably not the data rate but the number of connections. Many internet gateways can't handle many connections at the same time.

You can Limit your maximum amount of simultaneous connections in the Transmission preferences like so:

Preferences → Network → Maximum Peers per torrent

Try to keep these values very low at first. 5/10 is a good starting point. And increase them slowly as you find it working.

  • Note: Especially new torrents can show this behaviour. If you wait until there are enough seeders for a torrent, it'll be slowing down your browsing much less.

  • Note also: You shouldn't have to limit bandwidth. This is handled by the TCP/IP stack, no problem, in most cases. It tries to schedule packet delivery fairly.

share|improve this answer
    
Hello, thank you. I indeed had 60/200 which was much bigger than 5/10. I'll try that, hopefully this will solve the problem. –  Noz Dec 8 '10 at 21:44

Set your upload to 50% of your max upload bandwidth. You can have the download unlimited or limited. I set my download to 90% of max.

I have found with bandwidth saturating programs (Torrents), if the upload gets to > 75% of your max outbound limit, it severely hobbles all the data transfers on the system (Browsing). TCP/IP is a two way street, the packet replies have to get back to the sender before they can send another packet.

share|improve this answer
    
This point can't be stressed too much. Torrent-related slowness is in most cases the direct result of too much upload bandwidth. 50% may be a bit low for many connections, so try setting it to 70% of your outgoing bandwidth and see if it still works. –  loevborg Dec 9 '10 at 15:33

Limit the number of connections

BitTorrent is a protocol using a lot of simultaneous connections. While they may not consume a lot of bandwidth, they do consume a lot of administration work on the IPv4 routers and hosts to keep track of all the connection states.

Regular simple routers in a box you can buy for $40 aren't usually capable of maintaining more than 1000 connections before they go flat into the ground. This is because these devices have a very limited amount of memory to work with.

On the hosts a large number of connections may cause trouble because of security limits for a certain amount of connections per user and per process. These are usually viewed and altered using ulimit, but you should never run into it with the system defaults in Ubuntu with regular usage of your PC. However, BitTorrent can use a lot and may hit the limit on your PC.

See this answer on how to limit the number of connections per item and how to set a global limit in Transmission.

share|improve this answer
    
Thank you for your quick response and for the explanation, I thought bandwidth limits should be enough to avoid this problem, but it is obviously not. Thanks for sharing your knowledge! –  aVasile Jan 22 '13 at 1:09
    
About "consume a lot of administration work": Note that the Bit Torrent protocol uses TCP, which is a purely end-to-end protocol between hosts. The routers on the Internet do not allocate any resources that are persistent while the connection is active, they just forward the IP-packages. I'm not sure to which kinds of resources gertvdijk is referring. –  Lii Sep 7 '13 at 12:58

I didn't think of this myself, but it made a lot of sense once somebody pointed it out to me on here http://www.tomshardware.com/forum/36641-42-slow-internet-torrent-client

Put a limit on your uploads, most modems these days can take a thrashing, so download speeds are not usually your concern, put a limit on your upload speeds, your computer needs to be able to communicate with other servers on the internet, if your upload bandwidth is being used up completely then your computer will simply appear to be just silent

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.