Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i downloaded a stable version of Google Chrome. A .deb file got downloaded (i386). When I double click on it, Ubuntu software centre opens up and tries to install. But everytime an error pops up-

Internal Error .The file (/path to chrome) cannot be opened.

I have tried many methods but this just won't go. I don't think that the file is corrupted because this is the third time I have downloaded it.

Thanks in advance :)

share|improve this question
    
Run cd Downloads;sudo dpkg -i google-chrome*.deb in a Terminal window, and post the output here. –  Aaron Jul 22 '12 at 18:07
    
neph@ubuntu:~$ cd Downloads;sudo dpkg -i google-chrome*.deb [sudo] password for neph: Selecting previously deselected package google-chrome-stable. (Reading database ... 125666 files and directories currently installed.) Unpacking google-chrome-stable (from google-chrome-stable_current_i386.deb) ... –  Jonesh Sharma Jul 22 '12 at 18:12
    
dpkg: dependency problems prevent configuration of google-chrome-stable: google-chrome-stable depends on libnss3-1d (>= 3.12.3); however: Package libnss3-1d is not installed. dpkg: error processing google-chrome-stable (--install): dependency problems - leaving unconfigured Processing triggers for man-db ... Processing triggers for gnome-menus ... Processing triggers for desktop-file-utils ... Processing triggers for bamfdaemon ... Rebuilding /usr/share/applications/bamf.index... Errors were encountered while processing: google-chrome-stable neph@ubuntu:~/Downloads$ –  Jonesh Sharma Jul 22 '12 at 18:12

2 Answers 2

You are getting this error because a package the Google Chrome depends on to run is not installed. Run sudo apt-get install -f to fix this. You should then be able to run Google Chrome.

share|improve this answer
    
LOL should have tried that earlier. Thanks Aaron :) –  Jonesh Sharma Jul 22 '12 at 18:28
    
You're welcome :) If you are satisfied with my answer, click the check mark next to it. This lets people know that you have found an answer to your question. –  Aaron Jul 22 '12 at 23:43

Try to edit your sources.list file by adding this line :

 deb http://dl.google.com/linux/chrome/deb/ stable main

Then update your system:

 apt-get update

And install google chrome normally :

apt-get install google-chrome-stable
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.