Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have removed Windows 7 using GParted, and want my computer to boot straight into Ubuntu, but I still get the dual boot screen, how can I fix this?

share|improve this question
    
Possible duplicate: askubuntu.com/questions/6328/how-do-i-install-ubuntu –  Stephen Myall Jul 22 '12 at 17:57
1  
@StephenMyall Here, Ubuntu is already installed, and Windows is already removed. So this is not a duplicate of any question about how to install Ubuntu. –  Eliah Kagan Jul 22 '12 at 17:59
    
@Eliah Kagan understood, but its one of 3 options. Was hoping the asker would come back and state the same as you and add the clarity that overwriting the current installation is not an option. Askers needs to be more specific as the other 2 options are to resize the partition or reconfigure grub and I am sure there are duplicate answers for these also. –  Stephen Myall Jul 22 '12 at 18:05
1  
@StephenMyall Resizing the Ubuntu system's / partition will not change what appears on the GRUB menu. sudo update-grub (or sudo os-prober) is needed either way. –  Eliah Kagan Jul 22 '12 at 18:07

4 Answers 4

In the Ubuntu system, run this command in the Terminal:

sudo update-grub

That will rebuild the list of available operating systems, and Windows will no longer appear on the list.

There still may be a list, since you can choose between different kernel versions, or to test your system's RAM.

So if you find you still don't like the menu, you can make it appear for a shorter time.

You can even make it appear for no time at all, by setting the timeout to 0. Then, if you find you do need to access it, hold down Shift while booting, and it will appear.

share|improve this answer

Boot into Ubuntu and then run the following in the terminal, it will update your grub and then you should only see Ubuntu

 sudo update-grub

If this works and you want to hide the grub screen and not have to select any kernels at boot run

gksudo gedit /etc/default/grub

edit the GRUB_HIDDEN_TIMEOUT_QUIET=false to read GRUB_HIDDEN_TIMEOUT_QUIET=true

I would also recommend changing GRUB_HIDDEN_TIMEOUT=0 to GRUB_HIDDEN_TIMEOUT=1 as it will make it easier to press Shift or Esc to show the grub menu if you need to select old kernels(Previous Version of Linux). This is completely optional, I find it a more reliable way to get to grub menu when needed. It will slow down the boot by that 1sec that the grub is waiting for a key press.

Note: if you change GRUB_HIDDEN_TIMEOUT_QUIET or GRUB_HIDDEN_TIMEOUT you will need to re-run

sudo update-grub
share|improve this answer

Open a terminal and run the command -

sudo update-grub

it will remove windows entry.

if you don't want to see grub menu (if it is still showing) open /etc/default/grub. to do this run this command -

sudo gedit /etc/default/grub

Find GRUB_HIDDEN_TIMEOUT and GRUB_HIDDEN_TIMEOUT_QUIET and change as follows-

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true

after doing these run this command again -

sudo update-grub
share|improve this answer

Log in as sudo , then go to /boot/grub/grub.cfg file ,note the position of the description of ubuntu os , ( the position of installed OS begin with 0 ) so if you have only ubuntu note the position 0 Then search the parameter set default and set the value to 0 :

set default="0"

Like this you configure your system to boot with the OS with the position 0 ( the first one ) I hope that helps you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.