Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to play a movie I purchased from Google Play, the movie player (same Flash-based one used by YouTube) spits out the following error message over a background of faux-TV-static:

An Error Occurred. Please Try Again Later.

This is super-frustrating because I had just paid REAL money ($3.99) to watch the movie, as opposed to, you know, going someplace illicit to download it for free.

All other YouTube videos play fine for me, including the freaking Google Play trailer for the movie I bought! Sheesh. I Googled around for solutions, but I guess Google Play is too cutting edge for Ubuntu, because most of the solutions (in Ubuntu Forums, for example) recommended installing a Linux-specific Firefox plugin called Flash-Aid that essentially runs a configurable set of shell commands to ensure that you have the latest Flash from Adobe installed, and that you do not have any of the possibly conflicting free implementations of Flash installed (Gnash, etc). Suffice it to say, installing and running Flash-Aid did not help.

Also, I would add, I experienced the same error message trying to play the movie in Chromium.

share|improve this question
    
I think you need to report this issue to Google, as this isn't really an appropriate question for Ask Ubuntu, but a problem with software from Google which is not part of Ubuntu itself. –  dobey Jul 22 '12 at 16:32
    
Didn't you also post this solution? –  user25656 Jul 22 '12 at 17:20
    
dobey and vasa1, yes and yes. I posted here with the intention of answering my own question (since I had struggled to find the answer via Google previously and thought this might help someone in the future), but I had to wait the mandatory 8 hours for a first time user of Ask Ubuntu to answer my own question. –  Justin Watt Jul 23 '12 at 13:44

2 Answers 2

up vote 21 down vote accepted

Answering my own question because I was unable to find the solution anywhere on the Internet, and so I eventually had to turn to Google support, who incredibly responded with a solution!

They pointed me to the following Adobe support page:

Problems playing protected video content | Ubuntu Linux, Flash Player 11

Which had me run the following 3 commands to install a necessary hardware abstraction layer and clear out some cached Flash data.

sudo apt-get install hal
cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

I was able to play their DRM-test movie (Grr, DRM), so I guess it's working...

share|improve this answer
    
Thanks a lot, this also helped with Chrome. Instead of removing those specific folders, I cleared the ~/.adobe/Flash_Player folder and the movie started playing. –  Mendhak Sep 29 '12 at 10:18
    
Thanks man, I had this same problem and following these steps solved it for me! Now only need to figure out why full-screen video quality is bad... –  Suman Feb 9 '13 at 2:05
1  
This worked for me a few weeks ago, but now the player is saying that "I need to upgrade flash". The Chrome version of flash doesn't display this message but just buffers forever. –  Eponymous Apr 14 '13 at 2:41

As of today, October 10th, 2013, using Google Chrome version 30.0.1599.66, I can watch pay Google Play movies using the HTML 5 player instead of Flash without problems.

You need to go to this link and enable HTML5 use in youtube. Afterwards Google Play movies in Chrome will use it instead of the Flash Player.

Firefox doesn't seen to work, it tries to load the HTML5 player but fails and defaults to the Flash Player.

share|improve this answer

protected by Community Jul 10 '13 at 20:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.