Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So for the past few days, an issue has arisen that can't be ignored anymore with Ubuntu 12.04 on my Dell Studio XPS 1640 laptop. I've had 12.04 installed on it for months with no problems until recently.

Now, randomly occurring, my internal speakers will sometimes beging a routine of consistent (every 1.2 seconds or so) cracking/popping/clicking (no idea how to describe, it's kind of that sound you hear when your speakers go 'oh, I'm about to play some sound,' like a sound is TRYING to be played, but can't get out), even if the speaker volume is at 0 or muted entirely. Changing the sound volume does not change anything about this click noise.

I've also noticed that about 90% of the time, this sound is a precursor to my trackpad simply stopping working (the computer itself still remains operative though, as about 99% of the time, I can still use the keyboard). If I plug in a USB mouse, it still works fine.

Is there some sort of issue with my trackpad driver? I'm not sure what driver Ubuntu uses by default when detecting all of its hardware upon installation. Synaptic?

Any help would be greatly appreciated; thanks!

share|improve this question
    
I noticed that whenever I have Gmail open on Google Chrome, the crackling noise happens. There is no noise on Chromium and Firefox. So I think there's the bug in Google Chrome –  functionptr Aug 5 '12 at 22:20

2 Answers 2

OP's question first:

The ticking is most probably caused by one of three factors:

  • PulseAudio/Alsa problem, but muting should usually fix that
  • Driver/hardware problem, e.g. with the Realtek codec chip -- not fixable without further troubleshooting, may not even be fixable.
  • Electrical/RF interference issue, like the clicking you hear in unshielded speakers when a GSM cell phone is nearby and is transmitting/receiving -- this would be the most likely explanation considering that a touchpad failure always follows. Perhaps something wrong with the touchpad's USB or PS/2 connection, or its driver?

Your (function)'s issue:

Since you're sure this seems to be a Google Chrome issue, you should check by installing the pavucontrol package, starting Pulse Audio Volume Control and Chrome, and checking to see if you see sources like the below in the Playback tab, along with associated VU meter activity:

enter image description here

  • If you see any, try with Chromium too and consider filing a bug.
  • If not, this may not be a Chrome issue and you may have problems similar to the OP's.
share|improve this answer

There is a bug report on Launchpad, but nothing has been done! For me, the crackling sound is every 2 seconds, but I don't have touchpad problems...

Edit: By the way, this happened to me after a fresh Ubuntu 12.04 CD install.

Second Edit: This is happening to me again!

share|improve this answer
1  
The ticking noise stopped after reboot, but may happen in the future. –  functionptr Aug 1 '12 at 17:11
    
Actually now its happening on about half of the reboots –  functionptr Aug 5 '12 at 17:13

protected by Community Nov 7 '12 at 11:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.