Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hayy guy i got a satellite l640 and i installed ubuntu 12.04 on it and i dont get the battery percentage ive tried a fair bit but this is my first time using linux.

Ive gone into the power option and ive installed battery status apps and still i get nothing. There was one saying how much amps and what not the battery has and it all has 0.00 for everything, ive also tried the terminal cammands to see the percentage and that doesnt work. Is there anything i can do or should i just got back to windows.

share|improve this question

2 Answers 2

Just passed by this post while searching for a similar issue with fan on my Toshiba Satellite L650.

If your problem has not been solved you can try this. This works on my machine perfectly.

Download these two files and place 01_acpi in /etc/grub.d/ and chmod +x it with root privileges. Then place dsdt.aml in /boot and run update-grub2 in terminal.

After rebooting the machine, the battery applet should work fine.

Here are the links to the files.

01_acpi
dsdt.aml

share|improve this answer
    
I re-read your post and somewhere it looks like that you'll feel some problems in performing the tasks. here is a little more help about it. While copying the files to respective directories you'll need the root privileges, you can easily escalate to root by typing in a terminal gksu nautilus. This will ask for root password and then open a window with root privileges. after copying the files to respective directories run these commands in terminal: sudo chmod +x /etc/grub.d/01_acpi sudo update-grub2 And reboot your system. –  Gufran Aug 31 '12 at 13:32

I'v provided the exact command above, if you have placed the file at /etc/grub.d/01_acpi then just copy and paste this command in terminal

sudo chmod +x /etc/grub.d/01_acpi

You may also use Nautilus to do the same, just fire up a terminal and type gksu nautilus, enter password when prompted and Nautilus window will appear. Go to File system > etc > grub.d find the file 01_acpi Right click on it and go to properties > permission and check the box Allow executing file as program Thats all!

share|improve this answer

protected by Community Apr 10 '13 at 12:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.