Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I thought I would try out the new webapps ppa and everything seems to be working fine. However, google reader now floods my messaging menu with all my feeds and turns the icon blue. How can I remove a specific site (google reader) from accessing webapps after I have accepted it?

share|improve this question

9 Answers 9

up vote 78 down vote accepted
+50

Update

Easy way for 12.10 onwards :

Goto the software center and search for the specific web app and uninstall it. Like

unity-webapps-gmail or unity-webapps-googledocs


Hard way, For 12.04 ,and later ubuntu versions

Press Alt + F2 , run dconf-editor.

Now goto com → canonical → unity → webapps.

Edit Allowed domain value and remove the undesired entry.

enter image description here

To prevent any more pop up for a site, add the site url to:

firefox :Edit>preferences>General> Desktop integration > exception

or

chrome : Settings > Extension > Desktop integration > Exception

share|improve this answer

quickest solution : go to browers' extensions/addons setting and disable all mentioning ubuntu - so for firefox do : URL : about:addons chrome use tools -> extentions

share|improve this answer

If you have already «removed» the webapp with dconf-editor or unsettings and it still shows on the dash, then you have to manually delete it.

  1. Open the file manager
  2. Click View > Show Hidden Files (alternatively CTRL + h)

enter image description here

  1. Open this folder: .local
  2. Open this folder: share
  3. Open this folder: applications
  4. Search the «desktop» file you want and delete it.

Done!!

share|improve this answer

You can use Unsettings to enable and disable installed web apps:

enter image description here

In the "Web apps" tab remove the undesired domains from the "Pre-authorized" (1) or "Enabled" (2) fields (that are the allowed-domains and preauthorized-domains entries in dconf-editor) and at them to the "Disabled" (3) field, if you do not want to be asked for them any more (dontask-domains in dconf-editor).

Use the "Enable Web apps" switch (4) to switch off the whole web apps support.

share|improve this answer

(A small addition to Web-E's excellent answer.)

Go to the Dash → Ubuntu Software Center → search 'unity-webapps'

You'll now see a list of all the web apps supported by the Unity desktop. Web apps you've installed will have a tick mark on them, and from there installing/removing web apps should be goddamn easy!


WARNING! Do NOT remove the unity-webapps-service package (titled "Service for Web Apps integration with the Unity desktop"). This program runs the Desktop service used for Web Apps integration with Unity desktop.


Ubuntu Software Center search results for 'unity-webapps'

share|improve this answer

Drag the webapp from the dash to the trash icon. Works for me.

share|improve this answer
1  
it just close the application, doesn't uninstall it. If you reopen the site, the icon will appear again. –  fain182 Oct 20 '12 at 10:32

I couldn't find the web app in the Software Center, so I just used apt-get:

sudo apt-get remove unity-webapps-gmail

or

sudo apt-get remove unity-webapps-googledocs
share|improve this answer

The .desktop files for these web applications are located in ~/.local/share/applications. Removing these files (e.g. Googleplusgooglecom.desktop, LinkedInlinkedincom.desktop) will immediately remove the entries from the messaging menu.

Source: http://ubuntuforums.org/showthread.php?p=12267655

share|improve this answer
3  
This is the only thing that worked for me. This response should be marked as the answer –  M.P. Jun 22 '13 at 15:58

There definitely needs to be an easier way, but for now, you can use dconf-editor and remove the URL from the "allowed-domains" list at com → canonical → unity → webapps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.