Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Trouble downloading updates due to “Hash sum mismatch” error

Every time after I run Software Updates, and have installed all the updates, the Software Updates Manager will show "The last check for updates was over a week ago. Please click Check for Updates to check."
But the last update check was just minutes ago. How can I fix that?
I checked the package history, and under Today there's all the updates I've installed minutes age. It seems normal. And the system date and time are correct.
I am using Kubuntu Desktop 12.04 x86-64 btw.

Edit: Done sudo apt-get update
Tail output:

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/extras.ubuntu.com_ubuntu_dists_precise_main_source_Sources  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/extras.ubuntu.com_ubuntu_dists_precise_main_binary-amd64_Packages  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_precise-security_main_source_Sources  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question

marked as duplicate by Jorge Castro, hbdgaf, LnxSlck, Mitch, Scott Severance Sep 27 '12 at 13:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Is the clock and calendar on your computer showing the correct time and date? –  arochester Jul 22 '12 at 8:23
    
@arochester Yes, it is. –  WiSaGaN Jul 22 '12 at 8:26
    
How is your time and date format set? –  Mitch Jul 22 '12 at 10:01
    
@Mitch local UTC+8 –  WiSaGaN Jul 23 '12 at 11:50
    
It's not a duplicate, the problem is still there when I tried the method in that question... Such a shame... –  WiSaGaN Oct 8 '12 at 8:37

2 Answers 2

Update the sources from command line:

sudo apt-get update

if there is no error at end, next time it should report correctly.

Update: As there is some has mis match. Do the following

Remove all contents from list directory

sudo rm -fR /var/lib/apt/lists/*

Then reload again

sudo apt-get update

share|improve this answer
    
There's some checksum mismatch in the end. I've added the detailes in the question. –  WiSaGaN Jul 22 '12 at 9:39
    
What's the implication of this? Is it really safe to delete all files under that directory? –  WiSaGaN Jul 23 '12 at 6:45
    
Yea, it will download the files defining the sources. Which source file need to be downloaded is already listed in sources.lst file. –  Web-E Jul 23 '12 at 7:04
    
I've tried what you suggested. The problem is still there. –  WiSaGaN Jul 23 '12 at 12:13

Probably some of your sources are wrong. Do you get any error when you perform

 sudo apt-get update

If so you need to remove or fix your sources.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.