Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As of a recent boot, my desktop folder is defaulting to ~/. I would prefer the default behaviour : the desktop directory should be ~/Desktop.

As a first way to solve my problem I tried

gconftool-2 --set --type bool /apps/nautilus/preferences/desktop_is_home_dir false 

It didn't work so I tried a second idea : I edited my ~/.config/user-dirs.dirs file. I changed the XDG_DESKTOP_DIR environment variable to $HOME/Desktop, which is the default, and also to the absolute path /home/<my user name>/Desktop. Neither value make it show, even after killing Nautilus and relogging.

What else could cause this behaviour ?

share|improve this question
    
What's the output of ls -l ~/Desktop in the Terminal? (You can edit your question to add this information.) –  Eliah Kagan Jul 23 '12 at 6:13

1 Answer 1

Thank you for your question Matthew, because I had the same problem and editing the ~/.config/user-dirs.dirs file worked for me (that is to say the second idea in your question).

Here is a third method :

  • install dconf Editor
  • launch dconf Editor from the Dash Menu
  • in the left panel, browse to org → gnome → nautilus → preferences
  • uncheck the box labelled "desktop-is-home-dir" in the right panel

It did not work for me but I hope it works for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.