Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
error occured while running sudo apt-get install -f

[sudo] password for rahul: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  gnome-icon-theme-full libgail-3-0 libgtk-3-0 libgtk-3-bin libqgpgme1
The following packages will be upgraded:
  gnome-icon-theme-full libgail-3-0 libgtk-3-0 libgtk-3-bin libqgpgme1
5 upgraded, 0 newly installed, 0 to remove and 265 not upgraded.
409 not fully installed or removed.
Need to get 0 B/11.1 MB of archives.
After this operation, 110 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of libgtk-3-0:
 libgtk-3-0 depends on libgtk-3-common (= 3.4.1-0ubuntu1); however:
  Version of libgtk-3-common on system is 3.4.2-0ubuntu0.4.
dpkg: error processing libgtk-3-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgldi3:
 libgldi3 depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libgldi3 (--configure):
No apport report written because MaxReports is reached already
                                                               dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cairo-dock-core:
 cairo-dock-core depends on libgldi3; however:
  Package libgldi3 is not configured yet.
 cairo-dock-core depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing cairo-dock-core (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            dpkg: dependency problems prevent configuration of cairo-dock-plug-ins:
 cairo-dock-plug-ins depends on cairo-dock-core (>= 3.0.0.1); however:
  Package cairo-dock-core is not configured yet.
 cairo-dock-plug-ins depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing cairo-dock-plug-ins (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cairo-dock-plug-ins-dbus-interface-python:
 cairo-dock-plug-ins-dbus-interface-python depends on cairo-dock-plug-ins (>= 3.0.0.1-0ubuntu2); however:
  Package cairo-dock-plug-ins is not configured yet.
dpkg: error processing cairo-dock-plug-ins-dbus-interface-python (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgail-3-0:
 libgail-3-0 depends on libgtk-3-0 (= 3.4.2-0ubuntu0.2); however:
  Version of libgtk-3-0 on system is 3.4.1-0ubuntu1.
dpkg: error processing libgail-3-0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cairo-dock-plug-ins-integration:
 cairo-dock-plug-ins-integration depends on cairo-dock-core (>= 3.0.0.1); however:
  Package cairo-dock-core is not configured yet.
dpkg: error processing cairo-dock-plug-ins-integration (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of bamfdaemon:
 bamfdaemon depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing bamfdaemon (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libbamf0:
 libbamf0 depends on bamfdaemon (= 0.2.118-0ubuntu0.1); however:
  Package bamfdaemon is not configured yet.
dpkg: error processing libbamf0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libbamf3-0:
 libbamf3-0 depends on bamfdaemon (= 0.2.118-0ubuntu0.1); however:
  Package bamfdaemon is not configured yet.
dpkg: error processing libbamf3-0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libcaribou0:
 libcaribou0 depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libcaribou0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-gtk-3.0:
 gir1.2-gtk-3.0 depends on libgtk-3-0 (>= 3.3.18); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing gir1.2-gtk-3.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libclutter-1.0-0:
 libclutter-1.0-0 depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libclutter-1.0-0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-clutter-1.0:
 gir1.2-clutter-1.0 depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 gir1.2-clutter-1.0 depends on libclutter-1.0-0 (>= 1.9.16); however:
  Package libclutter-1.0-0 is not configured yet.
dpkg: error processing gir1.2-clutter-1.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgtksourceview-3.0-0:
 libgtksourceview-3.0-0 depends on libgtk-3-0 (>= 3.4.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libgtksourceview-3.0-0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of python-ubuntu-sso-client:
 python-ubuntu-sso-client depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
dpkg: error processing python-ubuntu-sso-client (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntu-sso-client:
 ubuntu-sso-client depends on python-ubuntu-sso-client (= 3.0.0-0ubuntu2); however:
  Package python-ubuntu-sso-client is not configured yet.
dpkg: error processing ubuntu-sso-client (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntu-sso-client-qt:
 ubuntu-sso-client-qt depends on python-ubuntu-sso-client (= 3.0.0-0ubuntu2); however:
  Package python-ubuntu-sso-client is not configured yet.
 ubuntu-sso-client-qt depends on ubuntu-sso-client (= 3.0.0-0ubuntu2); however:
  Package ubuntu-sso-client is not configured yet.
dpkg: error processing ubuntu-sso-client-qt (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntu-sso-client-gtk:
 ubuntu-sso-client-gtk depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 ubuntu-sso-client-gtk depends on python-ubuntu-sso-client (= 3.0.0-0ubuntu2); however:
  Package python-ubuntu-sso-client is not configured yet.
 ubuntu-sso-client-gtk depends on ubuntu-sso-client (= 3.0.0-0ubuntu2); however:
  Package ubuntu-sso-client is not configured yet.
dpkg: error processing ubuntu-sso-client-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on gir1.2-gtk-3.0 (>= 3.1.90); however:
  Package gir1.2-gtk-3.0 is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libedataserverui-3.0-1:
 libedataserverui-3.0-1 depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libedataserverui-3.0-1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libpanel-applet-4-0:
 libpanel-applet-4-0 depends on libgtk-3-0 (>= 3.3.8); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libpanel-applet-4-0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on libedataserverui-3.0-1 (>= 3.2.3); however:
  Package libedataserverui-3.0-1 is not configured yet.
 gnome-panel depends on libgtk-3-0 (>= 3.3.8); however:
  Package libgtk-3-0 is not configured yet.
 gnome-panel depends on libpanel-applet-4-0 (>= 2.91.93); however:
  Package libpanel-applet-4-0 is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgtk-3-bin:
 libgtk-3-bin depends on libgtk-3-0 (>= 3.4.2-0ubuntu0.2); however:
  Version of libgtk-3-0 on system is 3.4.1-0ubuntu1.
 libgtk-3-bin depends on libgtk-3-common (= 3.4.2-0ubuntu0.2); however:
  Version of libgtk-3-common on system is 3.4.2-0ubuntu0.4.
dpkg: error processing libgtk-3-bin (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-icon-theme-full:
 gnome-icon-theme-full depends on gnome-icon-theme (= 3.4.0-0ubuntu1); however:
  Version of gnome-icon-theme on system is 3.4.0-0ubuntu1.1.
dpkg: error processing gnome-icon-theme-full (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-icon-theme:
 gnome-icon-theme depends on libgtk-3-bin; however:
  Package libgtk-3-bin is not configured yet.
dpkg: error processing gnome-icon-theme (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-panelapplet-4.0:
 gir1.2-panelapplet-4.0 depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 gir1.2-panelapplet-4.0 depends on libpanel-applet-4-0 (>= 2.91.93); however:
  Package libpanel-applet-4-0 is not configured yet.
dpkg: error processing gir1.2-panelapplet-4.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-applets:
 gnome-applets depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
 gnome-applets depends on libpanel-applet-4-0 (>= 2.91.93); however:
  Package libpanel-applet-4-0 is not configured yet.
 gnome-applets depends on gnome-panel (>= 2.91.91); however:
  Package gnome-panel is not configured yet.
 gnome-applets depends on gnome-icon-theme (>= 2.15.91); however:
  Package gnome-icon-theme is not configured yet.
 gnome-applets depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 gnome-applets depends on gir1.2-panelapplet-4.0; however:
  Package gir1.2-panelapplet-4.0 is not configured yet.
dpkg: error processing gnome-applets (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of awn-applet-cpufreq:
 awn-applet-cpufreq depends on gnome-applets; however:
  Package gnome-applets is not configured yet.
dpkg: error processing awn-applet-cpufreq (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of awn-applets-all:
 awn-applets-all depends on awn-applet-cpufreq; however:
  Package awn-applet-cpufreq is not configured yet.
dpkg: error processing awn-applets-all (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cairo-dock:
 cairo-dock depends on cairo-dock-core (>= 3.0.0.1-0ubuntu1); however:
  Package cairo-dock-core is not configured yet.
 cairo-dock depends on cairo-dock-plug-ins (>= 3.0.0.0beta1); however:
  Package cairo-dock-plug-ins is not configured yet.
 cairo-dock depends on cairo-dock-plug-ins-integration (>= 3.0.0.0beta1); however:
  Package cairo-dock-plug-ins-integration is not configured yet.
 cairo-dock depends on cairo-dock-plug-ins-dbus-interface-python (>= 3.0.0.0beta1); however:
  Package cairo-dock-plug-ins-dbus-interface-python is not configured yet.
dpkg: error processing cairo-dock (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of empathy:
 empathy depends on libgtk-3-0 (>= 3.3.6); however:
  Package libgtk-3-0 is not configured yet.
 empathy depends on gnome-icon-theme (>= 2.30.0); however:
  Package gnome-icon-theme is not configured yet.
dpkg: error processing empathy (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgrip0:
 libgrip0 depends on libgtk-3-0 (>= 3.0.8-0ubuntu1); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libgrip0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of eog:
 eog depends on libgrip0; however:
  Package libgrip0 is not configured yet.
 eog depends on libgtk-3-0 (>= 3.3.18); however:
  Package libgtk-3-0 is not configured yet.
 eog depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 eog depends on gnome-icon-theme (>= 2.19.1); however:
  Package gnome-icon-theme is not configured yet.
dpkg: error processing eog (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libevince3-3:
 libevince3-3 depends on libgail-3-0 (>= 3.0.0); however:
  Package libgail-3-0 is not configured yet.
 libevince3-3 depends on libgrip0; however:
  Package libgrip0 is not configured yet.
 libevince3-3 depends on libgtk-3-0 (>= 3.0.2); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libevince3-3 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libnautilus-extension1a:
 libnautilus-extension1a depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libnautilus-extension1a (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of evince:
 evince depends on libevince3-3 (= 3.4.0-0ubuntu1.1); however:
  Package libevince3-3 is not configured yet.
 evince depends on libgtk-3-0 (>= 3.0.2); however:
  Package libgtk-3-0 is not configured yet.
 evince depends on libnautilus-extension1a (>= 1:2.91); however:
  Package libnautilus-extension1a is not configured yet.
 evince depends on gnome-icon-theme (>= 2.17.1); however:
  Package gnome-icon-theme is not configured yet.
dpkg: error processing evince (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of evolution-data-server:
 evolution-data-server depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing evolution-data-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-caribou-1.0:
 gir1.2-caribou-1.0 depends on libcaribou0 (= 0.4.2-1ubuntu1); however:
  Package libcaribou0 is not configured yet.
dpkg: error processing gir1.2-caribou-1.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-gkbd-3.0:
 gir1.2-gkbd-3.0 depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
dpkg: error processing gir1.2-gkbd-3.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-gtksource-3.0:
 gir1.2-gtksource-3.0 depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 gir1.2-gtksource-3.0 depends on libgtksourceview-3.0-0 (>= 3.3.4); however:
  Package libgtksourceview-3.0-0 is not configured yet.
dpkg: error processing gir1.2-gtksource-3.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-themes-standard:
 gnome-themes-standard depends on libgtk-3-0 (>= 3.3.14); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing gnome-themes-standard (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libmutter0:
 libmutter0 depends on libclutter-1.0-0 (>= 1.9.10); however:
  Package libclutter-1.0-0 is not configured yet.
 libmutter0 depends on libgtk-3-0 (>= 3.3.7); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing libmutter0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-mutter-3.0:
 gir1.2-mutter-3.0 depends on gir1.2-clutter-1.0; however:
  Package gir1.2-clutter-1.0 is not configured yet.
 gir1.2-mutter-3.0 depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 gir1.2-mutter-3.0 depends on libmutter0 (<< 3.5); however:
  Package libmutter0 is not configured yet.
 gir1.2-mutter-3.0 depends on libmutter0 (>= 3.4); however:
  Package libmutter0 is not configured yet.
dpkg: error processing gir1.2-mutter-3.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of librhythmbox-core5:
 librhythmbox-core5 depends on libgtk-3-0 (>= 3.1.4); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing librhythmbox-core5 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gir1.2-rb-3.0:
 gir1.2-rb-3.0 depends on gir1.2-gtk-3.0; however:
  Package gir1.2-gtk-3.0 is not configured yet.
 gir1.2-rb-3.0 depends on librhythmbox-core5 (>= 2.96); however:
  Package librhythmbox-core5 is not configured yet.
dpkg: error processing gir1.2-rb-3.0 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of gnome-settings-daemon:
 gnome-settings-daemon depends on libgtk-3-0 (>= 3.3.4); however:
  Package libgtk-3-0 is not configured yet.
dpkg: error processing gnome-settings-daemon (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntuone-client:
 ubuntuone-client depends on ubuntu-sso-client (>= 2.99.91); however:
  Package ubuntu-sso-client is not configured yet.
dpkg: error processing ubuntuone-client (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libsyncdaemon-1.0-1:
 libsyncdaemon-1.0-1 depends on ubuntuone-client (>= 3.0.1-0ubuntu1.0.1); however:
  Package ubuntuone-client is not configured yet.
dpkg: error processing libsyncdaemon-1.0-1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of ubuntuone-client-gnome:
 ubuntuone-client-gnome depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
 ubuntuone-client-gnome depends on libnautilus-extension1a (>= 1:2.91); however:
  Package libnautilus-extension1a is not configured yet.
 ubuntuone-client-gnome depends on libsyncdaemon-1.0-1; however:
  Package libsyncdaemon-1.0-1 is not configured yet.
 ubuntuone-client-gnome depends on ubuntuone-client (>= 2.0.0); however:
  Package ubuntuone-client is not configured yet.
 ubuntuone-client-gnome depends on gnome-settings-daemon; however:
  Package gnome-settings-daemon is not configured yet.
dpkg: error processing ubuntuone-client-gnome (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libubuntuoneui-3.0-1:
 libubuntuoneui-3.0-1 depends on libgtk-3-0 (>= 3.0.0); however:
  Package libgtk-3-0 is not configured yet.
 libubuntuoneui-3.0-1 depends on libsyncdaemon-1.0-1; however:
  Package libsyncdaemon-1.0-1 is not configured yet.
 libubuntuoneui-3.0-1 depends on ubuntu-sso-client (>= 2.99.0); however:
  Package ubuntu-sso-client is not configured yet.
dpkg: error processing libubuntuoneui-3.0-1 (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 libgtk-3-0
 libgldi3
 cairo-dock-core
 cairo-dock-plug-ins
 cairo-dock-plug-ins-dbus-interface-python
 libgail-3-0
 cairo-dock-plug-ins-integration
 bamfdaemon
 libbamf0
 libbamf3-0
 libcaribou0
 gir1.2-gtk-3.0
 libclutter-1.0-0
 gir1.2-clutter-1.0
 libgtksourceview-3.0-0
 python-ubuntu-sso-client
 ubuntu-sso-client
 ubuntu-sso-client-qt
 ubuntu-sso-client-gtk
 apport-gtk
 libedataserverui-3.0-1
 libpanel-applet-4-0
 gnome-panel
 libgtk-3-bin
 gnome-icon-theme-full
 gnome-icon-theme
 gir1.2-panelapplet-4.0
 gnome-applets
 awn-applet-cpufreq
 awn-applets-all
 cairo-dock
 empathy
 libgrip0
 eog
 libevince3-3
 libnautilus-extension1a
 evince
 evolution-data-server
 gir1.2-caribou-1.0
 gir1.2-gkbd-3.0
 gir1.2-gtksource-3.0
 gnome-themes-standard
 libmutter0
 gir1.2-mutter-3.0
 librhythmbox-core5
 gir1.2-rb-3.0
 gnome-settings-daemon
 ubuntuone-client
 libsyncdaemon-1.0-1
 ubuntuone-client-gnome
 libubuntuoneui-3.0-1
ProE: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question

marked as duplicate by jokerdino, izx, Mitch, Eliah Kagan, hbdgaf Jul 22 '12 at 16:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Try sudo dpkg -r libgtk-3-0 and see if that helps. –  jokerdino Jul 22 '12 at 6:40
    
it doesn't work.....not able to remove.....dependency problem –  Rahul Sinha Jul 22 '12 at 15:22
add comment

1 Answer 1

up vote 4 down vote accepted

What I guess from your provided output is, you have several packages with higher versions than the available versions in your repository. And as a general rule, Apt always try to install highest version of the package and If you have a higher version installed in your system, apt simply refuses to downgrade and try to keep the installed latest version.

What can be the cause of the problem

I guess, You have enabled a PPA (My assumption becomes strong after seeing the package names with cairo-dock) and Installed some packages from it. Later, you disabled that PPA. Note that, PPA's have higher version of the packages than the Official Ubuntu repository.

When you tried to install a package (I guess, it is gnome-icon-theme-full) after disabling it, The apt tries to install it by satisfying it's dependencies. I see that, gnome-icon-theme-full depends on gnome-icon-theme package which in turn depends on a package named libgtk-3-bin, which is an essential package of gnome-system. And It might get updated when you used the PPA and the version now available in the repository is lower than the version required.

So, apt has no way, but to refuse to install since, it knows no easy way to downgrade a package

What can be a possible solution.

  • Try to remember what PPA's you enabled. If you didn't remove any PPAs , but simply disabled it, re-enable that PPA.

  • Then do this command sudo apt-get update

  • Then do what you tried such as sudo apt-get install gnome-icon-theme-full.

It should work now.

Another solution using aptitude

  • Aptitude can be used to downgrade packages. So, if the above method doesn't work, install aptitude,

     sudo apt-get install aptitude
    
  • Then run aptitude to do the job. such as

     sudo aptitude install gnome-icon-theme-full
    

    If it (aptitude) do not find a way to satisfy dependencies, it will/may propose a possible suggestion for doing downgrading some packages, and will ask you whether you are happy with the solution. Read the solution carefully, and If you see, your desired package is selected for installation and some other packages (among them libgtk-3-bin package) is selected for downgrade, Press Y to agree with the solution. If you do not happy, Press N to let aptitude to propose another possible solution.

Recommendation

My recommendation would be not to use PPA if you are not familiar with installing and removing packages much. If you must use a PPA, don't disable it and keep updating your packages with that PPA. Also, don't try experimental PPAs.

The solution that worked for OP

Since these types of problems are very much associated with the package in consideration, I saw this general solution did not help him much. The OP has confirmed that, he successfully downgrade the package libgtk-3-bin by using the below command

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libgtk-3-0_3.4.2-0ubuntu0.4_i386.deb

After successfully downgrading the problematic package, He used synaptic package manager to remove all broken packages.

Check this question for help to remove broken dependencies:

How do I locate and remove Broken Packages that I have installed?

share|improve this answer
    
how i can downgrade libgtk-3-0 pakage??????????/ –  Rahul Sinha Jul 22 '12 at 18:57
    
@sinharahul58 Did you tried the solutions? I gave two solutions. Please try to read the answer with concentration (Yes, I know the answer is a long one). –  Anwar Shah Jul 22 '12 at 19:02
    
i am even not able to install aptitud...............shows dependency error –  Rahul Sinha Jul 22 '12 at 20:00
    
thanks to make me understand the real problem.........really thanks.......actually follow works.......sudo dpkg -i --force-overwrite /var/cache/apt/archives/libgtk-3-0_3.4.2-0ubuntu0.4_i386.deb –  Rahul Sinha Jul 22 '12 at 20:39
    
after doing above ............it shows following error –  Rahul Sinha Jul 22 '12 at 20:49
show 2 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.