Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a hp laptop. It has a network switch that allows to disable wireless networking. It is blue when working, orange when not working. At least, that's what it was with 10.04. Now it is blue when working, but flashes with blue/orange when there is some sort of networking activity. I would like to go back to the time when it just stayed blue if on, rather than showing network activity. How to do that ?

edit: here is the command you asked:

and here is the second one:

share|improve this question
There are various tweaks for that problem, but all depend on the wireless card and the driver. It doesn't actually matter what brand or model of the laptop you have. To identify your wireless hardware, please add the output of sudo lshw -C network to the question. – mikewhatever Jul 22 '12 at 8:01
see edit............... – roy429 Jul 23 '12 at 18:51
Thanks, it's an Intel card. How about modinfo -F parm iwlwifi? – mikewhatever Jul 23 '12 at 19:03
see edit once again :) – roy429 Jul 25 '12 at 20:34
Thanks, and sorry for the fifty questions. – mikewhatever Jul 25 '12 at 21:17
up vote 2 down vote accepted

The following commands should work for you:

sudo rmmod iwlwifi

sudo modprobe iwlwifi led_mode=1

To make it permanent, run

gksudo gedit /etc/modprobe.d/iwlwifi.conf,

paste in options iwlwifi led_mode=1, then save and close.

share|improve this answer
wow you're good. It worked, thanks a lot. You seem to know quite a lot about this hardware wireless stuff, and since you already know what hardware I'm using from the questions you asked, please allow me to give you the link to another question I asked: – roy429 Jul 27 '12 at 18:57
Options for led_mode: 0 system default, 1 on/off (RF state), 2 blinking (activity), 3 off. – Substantial Aug 30 '15 at 13:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.