Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed 12.04LTS and have a DeskJet 1125C connected through USB. The problem: Sometimes it does not print - in print jobs is status Pending/Processing but print does not start. I discovered if I print some documents then next document simply doesn't print with status processing or status pending. The only way is to disconnect printer from USB and immediately reconnect then works OK some times.

share|improve this question

5 Answers 5

Running sudo service cups restart will restart the printing software, fixing the problem.

I'm a complete Linux novice, but I somehow I hit upon executing the command and it worked without a hitch (I was given a clue when I ran pgrep hp and it gave me 2 hp processes and one hp-cups process).

share|improve this answer

In case it helps anyone, I have these same symptoms (print jobs go to pending and never print) unless my printer is turned on after Ubuntu starts up. Therefore, if I have print jobs pending, turning the printer off and then on again is enough to get them going.

share|improve this answer
This worked for me! :-) – Hubro Jul 9 '13 at 11:20

Ok it seems i have fixed it with repalce /usr/lib/cups/filter/pdftops file with one from there:

share|improve this answer

I had this problem but nothing worked. What I did to solve it was go to printers from the dash, right-click my printer and then realised there was no tick next to "enabled". Once I clicked this, it worked again. Something I'd installed must have disabled it for some reason :/

share|improve this answer

The other answers are possibly right, but I've discovered it might be an issue with what you're printing in combination with the settings that you're using.

For example, I tried to print this simple PDF, which is just a black and white checkerboard, on my Deskjet 932C. I selected "photo paper" in my print options (because I was using photo paper) and not only did the job get stuck in my queue, but my printer also started to make grinding noises and then began flashing its lights.

So I power-cycled the printer. Printed a test page using normal paper, just to make sure my printer wasn't fried, and ran:

sudo service cups restart

and tried printing the checkerboard again with photo paper, and the same thing happened. Then I tried selecting "normal paper" from the options...and it printed perfectly.

I guess the "Print" options shown my some applications doesn't always mess with the actual printer being used.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.