Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I cannot install Ubuntu 12.04 64 bits on my new dell XPS 14 ultrabook. When I tried to install it from a usb drive or wubi the installer says: "No root file system selected".

The problem is that I cannot see my hard drives and I cannot create a new partition, delete one, etc., bc the buttons are disabled.


  • 3rd Generation Intel® Core™ i7-3517U processor (4M Cache, up to 3.0 GHz)
  • 14.0" HD+ (900p) Truelife Infinity Display with Skype-Certified Hi-Def Webcam
  • 8GB2 DDR3 SDRAM at 1333MHz
  • 500GB 5400 HDD with 32GB mSATA
  • NVIDIA® GeForce® GT 630M with 1GB GDDR5 VRAM

Any ideas?

Thanks in advance.

share|improve this question
Have you tried, clicking on the "Try Ubuntu" option first, then using GParted to view your disk partitions? You can modify your partitions with GParted while running a live session before you do the install. – Peachy Jul 22 '12 at 0:37
Hey, @user78484, how has the overall experience on this machine been? Specifically wrt Ubuntu. All hardware works? Sleep? Hibernate? Trackpad features? Wireless? Video card? Also, have you tried the Project Sputnik image? (Don't know if Sputnik works on anything but the XPS 13 though). Thanks! – JDS Jul 30 '12 at 22:52
Had the same problem and resolved it with Martin's answer, thanks. To answer JDS's question; the XPS 14 works perfectly from install, arguably better than windows 8. In Ubuntu the trackpad works, wireless works great (both 2.4 and 5GHz), sleep and hibernate both work hitherto without problems (I get the BSOD often when resuming from sleep in Windows 8). Graphics worked fine, however Ubuntu didn't detect my Nvidia graphics card which meant it was on all the time and affecting battery life (2-3h), installation of bumblebee corrected this and turned off the card and battery life is now 5-6 hours. – user99306 Feb 9 '13 at 12:12
up vote 11 down vote accepted

why don't you try this? I remember coming across a problem similar to yours.

Run this command as root:

dmraid -E -r /dev/sdX

Where 'X' is the letter that identifies your actual device.


share|improve this answer
That worked. Thank you, so much! – user78484 Jul 24 '12 at 18:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.