Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried System Settings -> Details -> Default Applications -> Web but it's not listed as a web browser.

I also tried using update-alternatives, and it's listed there, but setting this doesn't seem to change anything--when I try gnome-open http://www.something.com it still opens with firefox.

I also tried changing the gconf settings for /desktop/gnome/url-handlers/ but that doesn't seem to stick.

What can I do to make luakit my default browser?

share|improve this question

1 Answer 1

up vote 2 down vote accepted
+50

Try this. From a terminal:

$ mkdir -p ~/.local/share/applications/
$ echo "[Desktop Entry]
Version=1.0
Name=Luakit Web Browser
Comment=Browse the World Wide Web
GenericName=Web Browser
Keywords=Internet;WWW;Browser;Web;Explorer
Exec=luakit %u
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=luakit
Categories=GNOME;GTK;Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;
StartupNotify=true
Actions=NewWindow;" > ~/.local/share/applications/luakit.desktop
$ update-desktop-database ~/.local/share/applications/

Then in System Settings > Details > Default Applications, you should be able to select Luakit Web Browser.

share|improve this answer
    
Thanks! Works great. –  Jon Jul 30 '12 at 4:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.