Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

today I tried to install a dpkg but it fails, it happened when I tried to install kernel, too.

mahdi@mahdi-System:~$ sudo dpkg -i ~/Downloads/libgjs0_0.5-1ubuntu2_i386.deb
Selecting previously unselected package libgjs0.
dpkg: regarding .../libgjs0_0.5-1ubuntu2_i386.deb containing libgjs0:
 libgjs0c conflicts with libgjs0
  libgjs0 (version 0.5-1ubuntu2) is to be installed.
dpkg: error processing /home/mahdi/Downloads/libgjs0_0.5-1ubuntu2_i386.deb (--install):
 conflicting packages - not installing libgjs0
Errors were encountered while processing:
 /home/mahdi/Downloads/libgjs0_0.5-1ubuntu2_i386.deb

Any idea?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
libgjs0c conflicts with libgjs0

One of the packages that you have already installed conflicts with the package you're trying to install. The packages libgjs0 and libgjs0c both contain /usr/lib/libgjs.so.0 and assorted dependencies, but these are incompatible versions of the library, because they depend on different Mozilla libraries: libgjs0c is linked with libmozjs 1.8 whereas libjs0 is linked with xulrunner 1.9 (assuming that you're trying to install the package from lucid).

If you're trying to install a binary that's linked against libgjs, you need to have one that's linked against the libraries in your distribution. You may not be able to install a .deb package from an out-of-date PPA or a third-party source intended for Debian. Either grab a package that works on the Ubuntu release you're running, or recompile the source package against your Ubuntu release.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.