Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since Ubuntu's installation, sound never plays through the laptop speakers. However, I can get sound by listening through headphones plugged into the jack.

Any ideas on how to get the speakers to work?

I have an hp pavillion dv6 laptop running Ubuntu 12.04.

share|improve this question
    
Did you try to change the output device manually in Sound Settings? –  elmicha Jul 21 '12 at 15:42
add comment

2 Answers

up vote 0 down vote accepted

You should probably start here :

http://www.alsa-project.org/main/index.php/Help_To_Debug

Your problem is likely to be a bug in the "patch" code for the driver. (As in "patch panel" not "software patch".)

The process of working out what the problem is is influenced heavily by your sound hardware.

For similar problems with my Intel HDA setup, I found the HDA Analyzer utility to be helpful - this lets you manipulate card parameters manually. And also this codec graphing tool, which helps to visualize how the patch layout of the card should work.

Alas, advice for other sound hardware is outside my experience.

At a minimum level you will be able to feed back information to the ALSA team for future kernel versions. I was able to patch the kernel to fix my problem (my C is terrible, but the code concerned is quite simple), and get a fix into the main kernel with assistance from the team on the Ubuntu kernel IRC channel, but I appreciate this is probably not a standard user response to the problem :-)

share|improve this answer
    
Thank you kindly for the pointers. I was planning on finding a free weekend to try to delve into it a bit. But, strangely, the sound suddenly just worked. I think it may have been one of the many updates I okayed some time ago. Thanks again nonetheless. –  jonS90 Aug 3 '12 at 18:07
add comment

I have your laptop model and I've never gotten around to troubleshooting my headphone problems because I discovered a workaround: in alsamixer (either from terminal or the GUI version in repos) if I max out Master and zero out speaker the audio will come from my headphones..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.