Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever i start an app, its icon appears in the launcher. Is there any way to disable this behaviour for certain specific apps(like guake, rhythmbox, etc). I just want them to start without their icon appearing on the launcher. Any ideas. Help would be highly appreciated.

share|improve this question
    
Neither of those apps appear in the unity launcher for me and I have them both running right now. –  hbdgaf Jul 21 '12 at 11:37
    
@aking1012 Unity sometimes forgets to update launcher, that's a buggy behaviour, not a feature. –  jnv Jul 21 '12 at 11:42
    
@jnv pretty sure it's a feature. both of those are tray apps by default, not gtk windows. rhythmbox can then be made to appear in the launcher by opening its window. it gets removed again on "close" when it goes back to the tray. –  hbdgaf Jul 21 '12 at 12:25
    
@Bolt64 did you mean you want another application that does show up to be made not to or are you having a bug where they show up when they shouldn't –  hbdgaf Jul 21 '12 at 12:25
    
@aking1012 If I've understood the question correctly, the goal here is to have no entry in launcher while the window is open. Rhythmbox will run in background if the music is playing, but you have to open window eventually and then it creeps into launcher. –  jnv Jul 21 '12 at 13:06
add comment

1 Answer

Normally this can be done using window manager hint (_NET_WM_STATE_SKIP_TASKBAR), which can be triggered in Compiz using Window Rules plugin (manageable using compizconfig-settings-manager) or using wmctrl, for example:

wmctrl -r Rhythmbox -b add,skip_taskbar

This would normally hide icon from taskbar in most desktop environments. Unfortunately, Unity currently doesn't support these states for already opened window, there's even a failing test (test_invisible_windows.py) for Unity 5 with an elloquent comment: "We don't support changing window states after they've been mapped."

So unless there's some way to launch target applications with a required window state, this, otherwise standard solution, is a dead end.

There might be some Unity-specific solution specific (e.g. a key for a launcher/.desktop file).

Unfortunately, there doesn't seem to be any easy solution, so the best chance might be to revive bug #750728 or open the new one.

The aforementioned test was removed for Unity 6, so it seems that Unity developers aren't interested in fixing this bug (or it's a very low priority).

share|improve this answer
    
More importantly, i'm interested in guake not showing up on the launcher. It never did before but all of a sudden it's appearing on the launcher every time i activate it using the F12 key. If the non-appearance till now was a bug, it seems to be fixed now. Is there any way to get the old behaviour back? –  Bolt64 Jul 21 '12 at 15:38
    
It seems to be rather opposite, Guake's window has _NET_WM_STATE_SKIP_TASKBAR hint, so the non-appearance in launcher was correct behaviour; on the other hand, there are still apps which should appear in launcher but don't, like MySQL Workbench. You could try Unity 2D, maybe it behaves correctly. –  jnv Jul 21 '12 at 17:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.