Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Kubuntu 11.10 I could click the tray icon and deluge's window would show, but now on 12.04, nothing happens. Only the right click works, and it shows the context menu, but there are no icons. Also it doesn't show the tooltip with Download/Upload statistics when I hover the mouse on its tray icon.

Does anyone know how to make deluge respond to clicking its tray button with the left button of the mouse?

enter image description here

share|improve this question
up vote 0 down vote accepted

That is the application indicator which is default now for Ubuntu and as with all indicators there are no right-click or tooltip options.

The previous functionality which you are referring to is from the older systray which can be reverted-to in Preferences -> Interface by un-checking Enable Application Indicator.

There is a forum post where this was discussed in a bit more detail.

share|improve this answer
In the forum post it looks (from the screenshot at least) that they're talking about GNOME. My problem happens on KDE, however. – sashoalm Aug 3 '12 at 6:22
Have you tried changing the setting? The screenshot you provided is the indicator (i.e. not systray) which means you have the library installed in Kubuntu for it to be enabled. – Cas Aug 3 '12 at 12:58
I just tried it, and it worked. Thanks! – sashoalm Aug 4 '12 at 11:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.