Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running the Ubuntu 12.04 server edition (static LAN IP) and was tying to install SABnzbdplus using the apt as per instructions here: Ubuntu PPA Repository

Installation has gone smoothly and the server downloads etc no problem! The problem is that I have edited /etc/default/sabnzbdplus as the directions provided to:

# This file is sourced by /etc/init.d/sabnzbdplus
#
# When SABnzbd+ is started using the init script, the
# --daemon option is always used, and the program is
# started under the account of $USER, as set below.
#
# Each setting is marked either "required" or "optional";
# leaving any required setting unconfigured will cause
# the service to not start.

# [required] user or uid of account to run the program as:
USER=omar

# [optional] full path to the configuration file of your choice;
#            otherwise, the default location (in $USER's home
#            directory) is used:
CONFIG=

# [optional] hostname/ip and port number to listen on:
HOST=0.0.0.0
PORT=8080

# [optional] extra command line options, if any:
EXTRAOPTS=

My (omar) runlevel is N 2.

Not quite sure what to do because executing: /etc/init.d/sabnzbdplus Works fine and error free.

Not sure what to do here. Advice and assistance would be greatly appreciated!

Thanks,

share|improve this question
add comment

1 Answer

The guide forgot

sudo update-rc.d sabnzbdplus defaults

This command will add the links at the correct runlevels so that sabnzbdplus starts and stops when booting, rebooting, shutting down, etc.

edit: if you get the message that those links are already in place have a look at this question

edit2: or this one

share|improve this answer
    
I tried that and it didn't work. I just switched to Debian and all works well. –  Omar Mir Jan 2 '13 at 1:11
    
Oh that's too bad, glad you got it working though! –  Gerhard Burger Jan 2 '13 at 9:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.