Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently asked this question about how to encrypt software on my machine. One of the answers suggested Cryptkeeper, so I installed it from Ubuntu software centre. The installation proceeded without reporting any errors, but I am unable to use the software. I access it from my System Tools menu and absoultely nothing happens. Has anyone else experienced this problem? Is the best solution to uninstall and reinstall or is there something I am missing in how to use it (although I don't see how) ?? I have never experienced any problem like this before with installed software - it always 'just works'.

share|improve this question
    
Have you had a chance to try out the workaround indicated in the answer? –  izx Jul 22 '12 at 9:56
    
@izx I tried it but I use gnome not unity. Does this mean that I will have to enable Unity in order to use cryptkeeper? –  mathematician1975 Jul 22 '12 at 12:32

4 Answers 4

up vote 5 down vote accepted
  • The Cryptkeeper indicator doesn't show in the Unity panel on the top-right in 12.04. This is a known bug.

  • Until the bug is fixed, the workaround is to whitelist its indicator via dconf-editor; install it via the dconf-tools package if necessary.

  • Open dconf-editor, go down to Desktop-->Unity-->Panel, and add the highlighted part as shown in the screenshot. Then close.

    enter image description here

  • Logout, start Cryptkeeper, and the indicator should now appear as below:

    enter image description here

share|improve this answer
1  
Short way to do it is to run gsettings set com.canonical.Unity.Panel systray-whitelist "['all']" in a terminal –  Jazz Jul 21 '12 at 8:19
3  
No, that's a short way to basically disable the whitelist and not everyone may want to do that (because it can have unintended side-effects). –  izx Jul 21 '12 at 8:21
    
OK, fair enough. –  Jazz Jul 21 '12 at 8:34

As an alternative solution using gsettings check the existing value:

gsettings get com.canonical.Unity.Panel systray-whitelist

Which will give you a result similar to:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier']

Now simply set the value after adding 'Cryptkeeper':

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Cryptkeeper']"

This is exactly the same result as the original answer but preferring the command line over dconf-editor.

This also works well on Ubuntu 12.10. Just make sure you add Cryptkeeper to your startup programs for the icon to show on startup. Multiple icons will appear if you start the program more than once.

share|improve this answer

The workaround with whitelist works with Unity, only.

If your desktop environment is Gnome, then you (additionally) need to add "Notification Area" to the panel:

Move your mouse over the panel and press Super + Alt + Right-Click, then choose "Add to Panel" and select "Notification Area".

share|improve this answer
    
Yes this problem is solved the same way askubuntu.com/questions/121426/… –  Mark Butler Jan 16 at 15:51

For Ubuntu 12.10 Quantal Quetzal,
Please see How to make Startup Applications in ubuntu to make Cryptkeeper work.

For how to install,
I use Ubuntu Software Center and search Cryptkeeper and install.

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eric Carvalho May 1 '13 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.