Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

See this question.

The FN keys are not working

Using answer in this question I installed the asus-wmi-dkms_0.2_all.deb.gz package

Now, using xev I see that the keys emit keycodes (for backlight keys xev says for fn-f3 and fn-f4 keycode 237)

But no keyboard backlight, also volume keys have no effect

================ original question ========================================

I cannot enable the keyboard backlight Seems that the leds class is missing I've not found the classes used in Keyboard light hotkey (Fn + F3 and F4) rarely work on an Asus G60J

Description of my framework:

===========================================================

Machine: Asus N56V laptop

===========================================================

Software

  • Kubuntu 12.04 amd64

  • kernel (3.5.0.5-generic) and drivers from xorg-edgers fresh X crack ppa

===========================================================

Hardware and problems

  • after installation do not boot - SOLVED using boot-repair

  • every couple of hours the system freezes - SOLVED using 3.5 kernel

  • keybord FN keys - NOT WORKING

  • Keyboard backlight - NOT WORKING

  • Nvidia GEFORCE GT - NOT USED glxgears says 60 fps

  • Ethernet Atheros card - SOLVED install alx driver

  • external subwoofer - SOLVED adding options snd-hda-intel model=asus-mode4

==========================================================

Solutions

see the answers to the this and this question.

==========================================================

share|improve this question
1  
Please do not make multiple similar questions. Please use one question if they are related(as some of your questions are). –  hexafraction Aug 6 '12 at 18:44
add comment

3 Answers 3

up vote 6 down vote accepted

For N56V and N76V, you need :

  • a 3.5 kernel (from quantal)
  • to get the subwoofer
    • I add on /etc/modprobe.d/alsa-base.conf this line: options snd-hda-intel model=asus-mode4
    • reboot and select 2.1 output in audio pref
  • to get the fn keys + keyboard backlight
  • to get the GeForce (when you want)
    • install bumblebee and driver from x-swat repository
  • to get the Ethernet
    • build/install alx module (http://www.linuxfoundation.org/collaborate/workgroups/networking/alx)
share|improve this answer
    
Tried fn-keys all installed but no backlight now xev says for fn-f3 and fn-f4 keycode 237 In /sys didn't appeare any vew class as Seems that kekeys are sending codes but nothing is attached to these events also audio volume fn-f11 fn-f12 do not work Wha can I try? Thanks –  Mirto Busico Jul 24 '12 at 9:20
    
I added "options snd-hda-intel model=asus-mode4" and rebooted. 4.0 option showed up instead of 2.1 in sound pref. When I select 4.0 subwoofer works as "rear right" and rear left is empty. Normal speakers work normal (front left - front right). How can I add 2.1 option to sound preferences? –  Can May 13 '13 at 11:42
add comment

Only thing that works for me is echoing like this:

echo 1 > /sys/class/leds/asus::kbd_backlight/brightness

Keyboard light hotkey (Fn + F3 and F4) rarely work on an Asus G60J

share|improve this answer
    
If you were trying to answer the question, please elaborate so and flesh out your post a bit more as to why you recommend what (even more so as this question already has an accepted answer as indicated by the green check mark). Otherwise, please post comments and the such as actual comments, once you have gained enough reputation. –  FEichinger Oct 29 '12 at 21:24
add comment

I bought an Asus N56VM laptop recently and sent the company an email concerning the following problem: Do not know how to turn on the keyboard backlight.

The following answer (edited) from Asus solved my problem:

  1. Go to Control Panel to uninstall the ATK package.
  2. Download and reinstall the ATKACPI driver and hotkey-related utilities. Here's the link.
  3. Download and reinstall the KB Filter Driver. Here's the link.
  4. Use FN+F3/FN+F4 to adjust the backlight of the keyboard for a try.
share|improve this answer
    
Is this answer really about Ubuntu? Seems like Windows-specific to me. –  jrouquie Oct 27 '12 at 18:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.