Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Alienware m11x with Optimus Technology. I setup (Fresh Install) Ubuntu 12.04 with bumblebee as below. Please help me set up the HDMI output so that I can connect it to my monitor.

$ uname -a
Linux ubuntu 3.2.0-24-generic-pae #39-Ubuntu SMP Mon May 21 18:54:21 UTC 2012 i686 i686 i386 GNU/Linux

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)

$ dpkg --get-selections
bumblebee                                       install
bumblebee-nvidia                                install

$ bumblebeed -version
bumblebeed --version
bumblebeed (Bumblebee) 3.0
Copyright (C) 2011 The Bumblebee Project

Should xrandr normally show HDMI?

$ xrandr -q     
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 256mm x 144mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)



$ cat /etc/X11/xorg.conf 
Section "ServerLayout"
    Identifier "Layout0"
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "ConnectedMonitor" "DFP"
EndSection

$ cat /etc/bumblebee/xorg.conf.nvidia 
Section "ServerLayout"
    Identifier "Layout0"
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "ConnectedMonitor" "DFP"
EndSection

$ cat /etc/bumblebee/xorg.conf.nouveau 
Section "ServerLayout"
    Identifier     "Layout0"
    Screen         "Screen0"
    Option         "AutoAddDevices" "true"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nouveau"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
EndSection

and finally the biggest config file below:

$cat /etc/bumblebee/bumblebee.conf 
[bumblebeed]
VirtualDisplay=:8
KeepUnusedXServer=true
ServerGroup=bumblebee
TurnCardOffAtExit=false
NoEcoModeOverride=false
Driver=

[optirun]
VGLTransport=proxy
AllowFallbackToIGC=false
PMMethod=none

[driver-nvidia]
KernelDriver=nvidia-current
Module=nvidia
PMMethod=none
LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

[driver-nouveau]
KernelDriver=nouveau
PMMethod=none
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Any ideas on setting up the Optimus to output to the HDMI T.V.?

I want to enable my HDMI with my GeForce GT 540M.

share|improve this question
    
Do you guys know why xrandr does not show my HDMI output? –  Alexander Tritan Jul 21 '12 at 5:05
    
** Also, I notice that on my laptop, there is no "VGA" connector (analog thing for the monitors), there is only a HDMI connector which you can connect a tv with a hdmi cable.*** –  Alexander Tritan Jul 21 '12 at 5:07
    
So far still working on this issue 4 hours total man... its soo hard to get HDMI output in Ubuntu 1204. –  Alexander Tritan Jul 21 '12 at 7:38
    
Oops, hit enter by accident: i found online people said to update your nvidia drivers sudo apt-get install nvidia-* I tried this but a few reboots later xrandr -q doesnt seem to display the HDMI :( –  Alexander Tritan Jul 21 '12 at 7:39
2  
I'm very sorry that not all questions are answered as quickly as we strive to be. There are other Ubuntu help resources, but whether or not you decide to use those now, I counsel patience. Most of us have lives outside of Ask Ubuntu, school/jobs, and other commitments. We're volunteers who can't always respond quickly to help you or anyone else (and you'll find that's true of the other free support resources). If that doesn't work for you, you might consider buying support. –  hexafraction Aug 3 '12 at 13:33

2 Answers 2

as I'm sure you've realised by now, getting HDMI to work on an Optimus laptop using GNU/Linux is non-trivial, to put to mildly :) there is a pretty decent 95% solution, though, and you can read about it here:

http://www.webupd8.org/2012/08/get-hdmi-working-with-nvidia-optimus-on.html

i bought an optimus-enabled laptop (no non-optimus config. available for the spec. I was looking at), foolishly thinking "well, I'll just disable the optimus, and that will be fine!"... wish I hadn't...

share|improve this answer

I'm sorry that I can't offer a solution via xorg.conf, but perhaps this programm could resolve your issues:

sudo add-apt-repository ppa:nmellegard/disper-indicator-ppa
sudo apt-get update
sudo apt-get install disper disper-indicator

This will install a small indicator to your top bar for simple one-click display configuration. It's pretty much self-explanatory, so I'll leave the rest to you. Hopefully this will help.

Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.