Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The strangest thing started happening earlier this week: each time I try to log into my laptop account (ubuntu 12.04), I get a very short black screen with a few lines of text, then I get sent back to the login screen. Intriguingly enough, I can perfectly log into the guest account and into another non-admin account I had created before. I can access the command line via ctrl+alt+F1 and log myself into my account, but then I have no clue as to how further investigate this issue. Any help greatly appreciated.

share|improve this question
just a guess, but try logging in to Unity-2D instead – Jazz Jul 20 '12 at 23:57
In case you don't know, here's how – Jazz Jul 21 '12 at 0:00
Thanks for input. I've tried that, but the behaviour is exactly the same: it brings me back to the login screen. – Gil Tomás Jul 21 '12 at 0:13
up vote 3 down vote accepted

Log in on a TTY (ctrl+alt+f1), run this:


Of course, replace YOURUSERNAME with your actual username (don't read over the semicolon).

Now, try logging in again.

share|improve this answer
Wonderful, it worked! I must have accidentally given ownership of my account to the root user. – Gil Tomás Jul 21 '12 at 0:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.