Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently upgraded Ubuntu to 12.4 from 11.10 on my Lenovo T61. Suspend/Resume no longer works.

Anybody got any insights?

I've searched and tried a few things

  • there was a suggested grub update ... no joy
  • there were a couple of suggested sleep scripts ... no joy

I would greatly appreciate any tips or hints anybody might have. No suspend/resume for a laptop is a showstopper, either I fix this or dump Ubuntu and try another OS and I really want to stick with Ubuntu.

share|improve this question
    
Welcome Dave, can you help us help you. Can you provide more details on the "few things" you researched and grub update your referencing? –  Stephen Myall Jul 20 '12 at 21:48
    
When you ask a question on AU you are engaging someone to help you (I started the process by trying to get a better understanding of your issue) You didnt respond and found something that worked for you. Good luck and be sure to come back if you have any more issues. –  Stephen Myall Jul 21 '12 at 9:17
    
You're running into the built-in spam protection on the site, I've voted to reopen this, when the site lets you please fill in an answer, thanks! –  Jorge Castro Jul 21 '12 at 17:24
    
@DaveGamble Dave, your question is re-opened and would be nice to include that information you have on the comments has an answer. Care to do so? –  Bruno Pereira Jul 21 '12 at 19:50

2 Answers 2

I have a Lenovo T61 laptop (Intel® Core™2 Duo CPU T7500 @ 2.20GHz × 2) running Ubuntu 12.04

When I upgraded to Ubuntu 12.04 the suspend function failed. It would suspend, but then when I attempted to resume, I would get a blank screen and no key combination did anything, so I would be forced to re-boot.

However, one dialogue in searching for a solution gave me a clue, it mentioned issues with the Nivida driver 302.17

So, to fix you need to revert back to an earlier version (that had previously worked for me) ... specifically 295.49.

Instructions:

  1. Download 295.59 drivers and get it ready to run
    32 Bit i386

    cd ~/; mkdir nvidia295.49; cd nvidia295.49/
    wget -O NVIDIA-Linux-x86-295.49.run http://us.download.nvidia.com/XFree86/Linux-x86/295.49/NVIDIA-Linux-x86-295.49.run
    chmod +x NVIDIA-Linux-x86-295.49.run
    

    OR .. if you are 64 bit (amd64)

    cd ~/; mkdir nvidia295.49; cd nvidia295.49/
    wget -O NVIDIA-Linux-x86_64-295.49.run http://us.download.nvidia.com/XFree86/Linux-x86_64/295.49/NVIDIA-Linux-x86_64-295.49.run
    chmod +x NVIDIA-Linux-x86_64-295.49.run
    
  2. Disable nVidia Drivers from "Administration > Additional Drivers".

  3. You can't install the drivers if X Server is up

    • reboot to Recovery Mode... that took me to the terminal ...
    • but ... this might also work ...

      sudo service lightdm stop
      
  4. Once the X server is down and you just have a terminal, run the installed
    cd to the directory where you put it

    cd ~/nvidia295.49
    

    Now run it-

    32 bit:

    sudo sh ./NVIDIA-Linux-x86-295.49.run
    

    or 64 bit:

    sudo sh ./NVIDIA-Linux-x86_64-295.49.run
    

    Work through the installer.

  5. Reboot.

share|improve this answer

i managed to solve this by using System Settings -> Software & Updates -> Additional Drivers. By default it was selecter X.org - X Server - Nouveau display driver, and i switched to Nvidia binary driver - 331.38 from nvidia (proprietary, tested).

After reboot, everything works great, no more system freezes, screen flickers, hungs when accessing dashboard, even resume from sleeps works great.

Hope that it will help you. Regards.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.