Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I copied the xampp zip onto the desktop and executed this in a terminal:

sudo tar xvfz xampp-linux-1.5.3a.tar.gz -C /opt

When i tried to install xampp, I am getting this

error tar (child): xampp-linux-1.5.3a.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

Any help will be appreciated. Thanks in advance.

share|improve this question
    
Your location should point Desktop then.Goto terminal and type cd Desktop and then follow the steps. –  karthick87 Dec 8 '10 at 7:14
    
I did it in the same way but i am getting the above error again. –  user7063 Dec 8 '10 at 7:21
    
See my updated answer. –  karthick87 Dec 8 '10 at 7:22
1  
You have your file in Desktop right?Then just right click that file and select Extract here and then move it to /opt –  karthick87 Dec 8 '10 at 7:33
1  
Then create the directory sudo mkdir /opt –  karthick87 Dec 8 '10 at 9:29

3 Answers 3

Installing XAMPP

Note:

  • You should extract the source from the same location from where it is placed.
  • In your case you have it in your desktop.
  • So get into Desktop first by running this command in terminal cd Desktop
  • Now extract it by type this command
    sudo tar xvfz xampp-linux-1.5.3a.tar.gz -C /opt
  • In case you have downloaded it to you home directory, Your terminal will be in the right location after you've opened it.

Alternate way to Extract:

  • Right click your xampp-linux-1.5.3a.tar.gz file which is in Desktop and select Extract Here.
    alt text
  • After extraction you will find lampp in your Desktop.
    alt text
  • Right click on lampp and select Cut.
  • Now you have to paste it in /opt so type gksu nautilus /opt in terminal
  • It will Open opt folder,Right click and select paste.
share|improve this answer
    
I HAVE POSTED THOSE COMMAND IN MY QUESTIONS,THERE IS NOTHING DIFFERENT BETWEEN YOUR COMMAND AND MY COMMAND. SOLVE MY ERROR –  user7063 Dec 8 '10 at 7:15
    
I am not finding such dir in my computer. –  user7063 Dec 8 '10 at 9:00
    
@user7063 you don't need to write in all caps, we read every comment. :-) Have to tried following Karthick's instructions very closely? They should work. –  Stefano Palazzo Dec 8 '10 at 12:52
    
The most recent version of xampp is 1.7.3a not 1.5.3a. You can get it from sourceforge.net/projects/xampp/files/XAMPP%20Linux/1.7.3a/… –  lovinglinux Dec 8 '10 at 12:57
    
Can you post a link for that beautiful conky script? –  tinhed Dec 8 '10 at 16:24

The most recent version of xampp is not 1.5.3, but 1.7.3a. So I suspect that is what you have downloaded. If that is the case, then use this command:

sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt

Anyway, verify that the command you are using matches the version of the file. Put the downloaded file in your home directory (e.g. /home/yourusername/), not a sub-folder or somewhere else and execute the command above, replacing the numbers with the corresponding version. If the downloaded file is located somewhere else, you will need to cd into that directory before using the command above, otherwise the tar command will look for that file in your home directory and won't find it.

Then follow this tutorial: http://ubuntuforums.org/showthread.php?t=223410

share|improve this answer
    
You can also just write the first few letters of the file name and press TAB, bash will try to automatically complete the file name if it exists in this location. –  Stefano Palazzo Dec 8 '10 at 12:56

Installing XAMPP

Open the terminal.

You said you have placed the XAMPP archive on the desktop, so therefore you have to make sure that you have navigated to your desktop folder in the terminal:

cd ~/Desktop

Extract the files from the archive using the following command:

sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt

You would probably have to make sure that you have permissions to put files in XAMPP's web page directory:

sudo chmod a+rwx /opt/lampp/htdocs

Starting the server

To start XAMPP, enter the terminal and type the following line:

sudo /opt/lampp/lampp start

Make sure that the server is successfully installed by navigating to http://localhost/. You should see a page that tells you that XAMPP was successfully installed.

To stop the server, just type this:

sudo /opt/lampp/lampp stop

Setting up your web pages

Open the file browser and navigate to the /opt/lampp/htdocs directory. Place all your web pages in this directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.