Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use PulseAudio on top of jack, so I've turned pulse off and now want to start jack using qjackctl. However, this results in the following error log:

22:14:15.933 Patch Panel disabled
22:14:15.940 Reset statistics.
22:14:15.953 Changed ASLA connection.
22:14:15.970 D-BUS: Service available (org.jackaudio.service aka jackdbus).
Cannot connect to server socket err = File or directory not found
Cannot connect to server socket
jack server is not running or cannot be started
22:14:15.980 Updated visualization of ASLA connections
22:14:18.147 D-BUS: Unable to start JACK server
Cannot connect to server socket err = File or directory not found
Cannot connect to server socket
jack server is not running or cannot be started
Fri Jul 20 22:14:18 2012: Starting jack server...
Fri Jul 20 22:14:18 2012: JACK server starting in realtime mode with priority 10
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Cannot lock down 82246176 byte memory area (Cannot allocate memory)[0m
Fri Jul 20 22:14:18 2012: control device hw:0
Fri Jul 20 22:14:18 2012: control device hw:0
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Failed to acquire device name : Audio0 error : Cannot allocate memory[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Audio device hw:0 cannot be acquired...[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Cannot initialize driver[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: JackServer::Open() failed with -1[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Failed to open server[0m
Fri Jul 20 22:14:19 2012: Saving settings to "/home/jan/.config/jack/conf.xml" ...
22:14:24.418 Cannot connect to JACK server as client - connection failed. See message dialog for details.
Cannot connect to server socket err = File or directory not found
Cannot connect to server socket
jack server is not running or cannot be started

(Several messages were in German, I did my best translating them)

The pulseaudio process is defenitely not running.

I use Ubuntu 12.04 64 bit with an NVIDIA audio card.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Ok, got it: I had to add myself to the group audio:

usermod -a -G audio theusername
share|improve this answer
    
Even in the audio group jack can't allocate memory. –  btilford Oct 20 '12 at 3:12
    
I was doing this to no avail; had to log out & in again. Hope that saves someone 5 minutes. –  Thomas Dec 2 '12 at 6:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.