Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an WNDA3100v2 wireless USB dongle, which I got working via the ndiswrapper. But randomly it disconnects. Then to get it working I have to pullout the USB adapter and plug it back in.

I search the log files, and found the following line immediately after a disconnect in /var/log/syslog: ICMPv6 ND: ndisc_build_skb() failed to allocate an skb, err=-11.

That line appears like every second in the log.

I'm currently not using encryption on my wireless network (but using mac based security) since it kept asking me for my network key.

share|improve this question
    
I got T-mobile, worked perfectly for about 6 months in windows and Puppy linux, then one day, wouldn't work in linux, and on a number of machines and under various distributions of puppy linux, IE it' can't be changed settings because these are loaded off CD on boot up and I created about 10 of these discs for friends. Trouble is, I go to T mobile and they give me the lazy response, if it worked before it should work now, or if it works in windows it should work under linux, any answer that doesn't involve them looking into my problem. The thing will detect, I can set it up, and it connecxts, –  user143314 Mar 25 '13 at 16:06

3 Answers 3

up vote 1 down vote accepted

That adapter/version has the BCM4323 chip which has spectacularly poor support on Linux -- neither the b43 driver nor Broadcom's proprietary wl binary driver supports it.

The disconnects are probably related to the ndiswrapper/Windows driver rather than IPv6. I would try to consider replacing that with another dongle that has better Linux support.

share|improve this answer
    
I was afraid of that. I was hoping there would be a different driver of something like that. –  Wouter Carabain Jul 21 '12 at 5:49

I have been a PC tech, a systems admin, and a network admin. I did EVERYTHING to try and resolve this issue on my daughter's desktop. We are using a wireless USB Network adapter and more times than not the internet just crawled or cut out completely.

Things I tried: - Resetting the adapter - moving the adapter - reinstalling the adapter SW - using a different wireless USB adapter - AntiMalWare Scan - disabling the onboard wired adapter through Device Manager - Flashing Bios - updating USB drivers in Device Manager - Reinstalling Win 7 Ultimate from scratch

I was going crazy..... The signal was FULL at 4 to 5 bars at all times. (Her bedroom is on the 2nd floor... kind of far from the wireless router)

The resolution? Well.... I noticed that when I moved away from the adapter, the web pages loaded instantaneously. The problem was that even though it showed 4 or 5 bars, we were blocking the signal to the adapter when we were sitting in her chair). I moved the adapter using a long usb connector cable and situated it where it would not be blocked at all while sitting in front of the monitor.

The moral of the story? Before going nuts, move the adapter so that it is free and clear of all obstructions!!!! 4 or 5 bars mean nothing.... The signal bar may still show full even though the adapter is blocked.

share|improve this answer

Limit your download speeds in your torrent client to about 300-350 kb/s. There is also a command line program called trickle which can help you limit your download speeds of your updates and anything else. Run a search on that for how to you use. I'm using the same adapter and had the same problem. All is well have been connected all day and downloading at 350 kb/s which is tolerable...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.