Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to type in my native language Sinhala with SCIM..but nothing is working. (I heard about something called ibus could help.) I want to get the phonetic output in Sinhala Unicode, when I input some phrase in in English. Is there a way to fix this...? Appreciate any help, Thanks!

My SCIM settings :

enter image description here

enter image description here

share|improve this question
add comment

3 Answers 3

iBus is still significantly inferior for most of the half-dozen or so IMEs I use regularly, so it's still SCIM all the way for me. They both use the same modules (so an identical list of input-method engines, scripts etc. are available) but SCIM doesn't mangle any of them like iBus does in places.

For Sinhala in particular, the m17n engine works very nicely.

share|improve this answer
    
Could you get scim-m17n running in 14.04 trusty? –  Robert Siemer Apr 20 at 11:03
    
@RobertSiemer -- sadly not. the scim-m17n packages are broken (m17n extensions are not loaded, unlike in the screenshot above), and there doesn't seem to be any interest in fixing them, as the momentum is towards forcing people to use the frustratingly inferior iBus :( –  simon Apr 20 at 17:04
    
I so know what you're talking about... -- I could fix scim-m17n by moving m17n.so from /usr/lib/scim-1.0/1.4.0/IMEngine/ to /usr/lib/i386-linux-gnu/scim-1.0/1.4.0/IMEngine/ –  Robert Siemer Apr 20 at 22:35
add comment

We've got success! Gunnar Hjalmarsson has provided a patch that resolves the issue. I have a 64-bit system, and it works fine. I can't say about the 32-bit systems, although I expect it should work fine.

Here I am spelling out exactly what you need to do:

Add "ppa:gunnarhj/misc" to your system's Software Sources. Do this by typing "Software & Updates" in the dash and opening the tool by that name. Once it opens, go to the "other sources" tab and click on "add". In the window that opens, paste his PPA, i.e. "ppa:gunnarhj/misc". Once that is done it will ask you to click there to update the online sources. Once that is finished, then open "software updater" from the dash, and update your system. Make sure in Language Support that the keyboard input method system is still set to scim and not ibus. Then log out and log back in, and it'll be good to go.

If you want to directly read from his site, go the bug I have created on this issue. See Gunnar's post, and go to the link he gives. There you'll find more detail on the matter i.e. just what is in his ppa. But for those who are newb's, the directions I've given above will I think be easier to follow.

Enjoy using scim-m17n!

Regards, Swarup

share|improve this answer
    
The fixed scim-m17n package has now made it to trusty-updates, so it can be installed the ordinary way. Consequently I have removed it from ppa:gunnarhj/misc. –  Gunnar Hjalmarsson May 23 at 6:31
add comment
up vote 0 down vote accepted

Just leave SCIM alone and begin installing iBus.. which contains a lot of unicode languages. :-D To change the settings, goto system settings>iBus

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.