Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I finally got around to reinstalling ubuntu 12.04 (x86) on my computer and am having a whole slew of issues. Here are the main issues I am having in order of severity.

1) Random GTK (GUI?) crashes. Basically the screen suddenly goes black and I am brought back to the lock screen and have to log in again. So far this seems to happen more when I am doing something and the computer is not sitting idle, but I wager if I left it idle long enough it would do the same thing.

2) Cannot resume from suspend. I am using a laptop and when I close the lid and open it again the screen turns on, but its all black. The only way for me to get back to doing anything is to restart the computer.

3) Plymouth is using VGA resolution. Not the most severe of the issues, but something that still bugs me. I would like to get the random crashing solved first if possible.

At the moment, this is pretty much a fresh install. I have installed some applications, I installed gnome-tweak-tool, but read somewhere that that was causing a problem for someone so I deleted it.

My computer is an Alienware M15x. It has an nvidia graphics card and I have a feeling that is causing some of these problems. Instead of using the 'additional drivers' tool in ubuntu, I did this

How do I install the latest Nvidia drivers via the Additional Drivers tool?

to install the latest nvidia driver.

share|improve this question

closed as too localized by Jorge Castro, belacqua, izx, Uri Herrera, Mitch Aug 18 '12 at 6:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Newer alaienware has optimus enabled system. Does your laptop has optimus enabled? Post the output of lspci | grep VGA –  Web-E Jul 20 '12 at 14:33
3  
It would be more appropriate to post each question as an individual one and not as "5 in 1" –  Nickolas Jul 20 '12 at 15:53
    
regarding your first question, it would be better to mention when that happens like "when copying files" or "running a specific program" –  Nickolas Jul 20 '12 at 15:56
    
Thanks for the responses guys. My alienware is not a unit that uses optimus. Here is the output that you requested. 02:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce GTX 260M] (rev a2). Sorry, I don't know how to post the output into one of those gray boxes :S. –  user78231 Jul 20 '12 at 23:17
    
I didn't want to spam the site by posting multiple questions at once. I will do so next time. Thanks :). –  user78231 Jul 20 '12 at 23:20

1 Answer 1

1)For this question, you will have to provide more information regarding when the black screen occurs.

2)You may take a look at the following Bug Report as well as this Askubuntu question .

3)Run the following commands at terminal:

They will download the fix script and install it.

cd
wget http://launchpadlibrarian.net/57638460/fixplymouth
chmod +x fixplymouth
./fixplymouth

This will install the script and afterwards show you a list of available resolutions supported by plymouth.Simply select the one that suits you best.

NOTE :If something wrong happens you can restore your boot screen by following this tutorial.

share|improve this answer
    
I just tried it. It didn't work. Before I was getting an overblown logo and now I just get a blank purple screen. Thoughts? EDIT: I will try what you suggested for the second problem tonight. For the first problem, in a response above I mentioned when it happens. Basically it is completely at random. It does not seem to be something that I can reproduce. It has mostly happened when browsing the web, but thats because that is mostly all I have done. It also did it while in software center and qbittorrent. I haven't opened many other programs yet. –  user78231 Jul 20 '12 at 23:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.