Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This happens on some of my Ubuntu servers but not all. I just did a fresh install of Ubuntu server 12.04 and when began to install updates, my 600kb/sec download speed is suddenly cut to 3kb/sec after several seconds.

This happens irregardless of whether I use a bandwidth-limiting client like wondershaper.

I believe that this is an Ubuntu problem, as none of my other servers are experiencing this, including servers running other distros.

Any help is greatly appreciated!

share|improve this question
    
This might sound like a silly question but how are you testing this? You're not just doing it by testing the repository speed, are you, as that is liable to slow down in busy times. –  Oli Jul 20 '12 at 13:39
    
This happens when I issue apt-get install, aptitude update, aptitude safe-upgrade, etc. I would agree that repository speed can fluctuate, but this happens every single time I issue one of those commands. –  divided Jul 20 '12 at 13:45
add comment

1 Answer

But the speed is constant (and high) with other tests? Try: wget -O /dev/null http://speedtest.newark.linode.com/100MB-newark.bin

If it's just the repos that are slow, change to a different mirror. Here is a particularly elegant solution for automatically picking the best mirror on a server: How can I get apt to use a mirror close to me, or choose a faster mirror?

share|improve this answer
    
The speed test began around 500kb/sec and ended at 5.4kb/sec. –  divided Jul 20 '12 at 15:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.