Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu (and Mint) some important shortcuts for Blender does not work.

  • Alt + right click to select an edge loop (heavily used on all 3D softwares) doesn't work, a useless menu of Ubuntu pop up to ask if the application must be closed or minimize.

  • Ctrl + Alt + 0 to define the current view as the view of the camera minimize the application. This shortcut of Ubuntu is useless, it's faster to click on the minimize icon.

  • Ctrl + number to apply a subdivision surface level do nothing on Blender, it's one of the most used shortcut of Blender.

For the moment I stay on Windows 7 just to use these 3 shortcuts.

share|improve this question
add comment

1 Answer 1

Sorry this seems to be coming a bit late, I've only just seen your question.

To allow Alt+RMB, the best option is to switch the Alt key to the Super (Windows) key using dconf-tools.

sudo apt-get install dconf-tools

Under System Tools, you should now have dconf-editor. If not, just enter:

dconf-editor

in a terminal.

Open org -> gnome -> desktop -> wm and choose Preferences.

Look for mouse-button-modifer in the list. It will be set to , click on that to edit it and type:

<Super>

Press Enter to set the value. You don't need to "save" it. Just close the editor.

That will allow you to use Alt+RMB in Blender.

Unfortunately, this will disable the Alt part of the Ctrl+Alt+0 to align the camera to the current view :-)

To fix that, change the setting in Blender:

File -> User Preferences -> Input -> 3D View -> 3D View (Global)

Towards the bottom of the list, you'll see Align Camera To View, with it's default of Ctrl Alt Numpad 0. Click on that and it will ask you for a new key combination. I use the Super (Windows) key instead of Alt for this now, so just press Ctrl + Super + Numpad 0 to set that. Note that this will show as "Ctrl Cmd Numpad 0"

For your last problem, I'm not sure why you're having issues with the subsurf shortcuts. It's never been an issue for me, so I'm not sure what to advise. You could try the Blender input settings. They're under the same User Preferences -> Input tab, but they're listed in two places. You'll probably need to update them under both 3D View -> Object Mode and 3D View -> Mesh.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.