Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i try to watch a video with a high HD Resolution 1280 x 720 H264 in Ubuntu it isn't played smoothly. There stops and glitches occur. It's no problem of the CPU or graphicscard, because under windows there are no problems like this. Could it be a driver problem?

Update: For me VLC Player works best. No stops no glitches. Smplayer also looks good but the performance leaks same as the standart ubuntu video player in my case.

share|improve this question
    
What player are you using? I personally have different experience on different players. –  Marcos Roriz Junior Dec 7 '10 at 22:05
    
Are you using Flash? Or are you referring to a video playing in something like Totem? –  RolandiXor Dec 7 '10 at 22:06
    
Try VLC player. It plays many "difficult" formats smoothly. –  Vincenzo Dec 7 '10 at 22:19
    
the problems occur with the standart player in ubuntu. i currently checked vlc player and i'm impressed. it works so much better. –  NES Dec 7 '10 at 22:30

1 Answer 1

up vote 6 down vote accepted

You can't compare Windows and Linux, because video driver performance and features are different. For instance, if you are using nVidia you need a card that supports vdpau for best performance, which is equivalent to PureVideo in Windows. PureVideo supports many more cards. However, depending on your CPU, you can play HD videos smoothly without vdpau support. So depends on your video driver, CPU and also player settings.

It would help if you could provide more info about your video card and CPU.

Anyway, try smplayer Install smplayer

Is the best player IMO and plays even videos with resultions higher than 1080p on my Core2 Duo with nVidia 7300 GT (not vdpau).

Make sure you tweak smplayer. In the preferences, click the "Performance" section and select the option "Skip only on HD videos" in the "Loop filter" settings. In the "General" section, click the "Video" tab and make sure the "Output" driver is set to "xv".

share|improve this answer
    
The Notebook is not the latest but performance should suffice for play smoothly. Dual Core CPU 1,8 and a Ati Card with i know i learned is not the best choice for ubuntu :) I'll give smplayer a try also. –  NES Dec 7 '10 at 22:37
    
Smplayer also plays with glitches and not smoothly in spite i tweaked it with your settingsadvices. at the moment it looks as if only vlc is the only player at the moment to run smoothly. –  NES Dec 7 '10 at 22:44
    
Try to disable Desktop effects (Compiz). Anyway, if VLC works stick with it. –  lovinglinux Dec 8 '10 at 13:08
    
until xvba becomes a reality, ati is not the best choice for hd videos on linux. –  tinhed Dec 8 '10 at 16:33
    
before i switched completly to linux, i wasn't aware that ati isn't the best choice for a linux system. however in the meantime i think i have also learned that the ati cards also aren't the best choice at all (for windows) imho. –  NES Dec 8 '10 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.