Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 12.04 Desktop. Mic is not working. I tried same mic in different place,that is working. This is out put of 'pacmd list-sources' Please help me.

root@vijay# pacmd list-sources

Welcome to PulseAudio! Use "help" for usage information.

3 source(s) available.

index: 0
name: <alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor>
driver: <module-alsa-card.c>
flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE 
priority: 1050
volume: 0: 100% 1: 100%
        0: 0.00 dB 1: 0.00 dB
        balance 0.00
base volume: 100%
             0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max rewind: 0 KiB
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
             Stereo
used by: 0
linked by: 0
configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
monitor_of: 0
card: 0 <alsa_card.pci-0000_01_00.1>
module: 4
properties:
    device.description = "Monitor of High Definition Audio Controller Digital Stereo (HDMI)"
    device.class = "monitor"
    alsa.card = "1"
    alsa.card_name = "HDA NVidia"
    alsa.long_card_name = "HDA NVidia at 0xd6000000 irq 3"
    alsa.driver_name = "snd_hda_intel"
    device.bus_path = "pci-0000:01:00.1"
    sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
    device.bus = "pci"
    device.vendor.id = "10de"
    device.vendor.name = "NVIDIA Corporation"
    device.product.name = "High Definition Audio Controller"
    device.string = "1"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
index: 1
name: <alsa_output.pci-0000_00_1e.2.analog-stereo.monitor>
driver: <module-alsa-card.c>
flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: IDLE
suspend cause: 
priority: 1950
volume: 0: 100% 1: 100%
        0: 0.00 dB 1: 0.00 dB
        balance 0.00
base volume: 100%
             0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max rewind: 64 KiB
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
             Stereo
used by: 0
linked by: 0
configured latency: 371.52 ms; range is 1.00 .. 371.52 ms
monitor_of: 1
card: 1 <alsa_card.pci-0000_00_1e.2>
module: 5
properties:
    device.description = "Monitor of Built-in Audio Analog Stereo"
    device.class = "monitor"
    alsa.card = "0"
    alsa.card_name = "Intel ICH7"
    alsa.long_card_name = "Intel ICH7 with AD1888 at irq 22"
    alsa.driver_name = "snd_intel8x0"
    device.bus_path = "pci-0000:00:1e.2"
    sysfs.path = "/devices/pci0000:00/0000:00:1e.2/sound/card0"
    device.bus = "pci"
    device.vendor.id = "8086"
    device.vendor.name = "Intel Corporation"
    device.product.name = "82801G (ICH7 Family) AC'97 Audio Controller"
    device.form_factor = "internal"
    device.string = "0"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
index: 2
name: <alsa_input.pci-0000_00_1e.2.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE 
priority: 9959
volume: 0:  94% 1:  94%
        0: -1.50 dB 1: -1.50 dB
        balance 0.00
base volume:  42%
             -22.50 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max rewind: 0 KiB
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
             Stereo
used by: 0
linked by: 0
configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
card: 1 <alsa_card.pci-0000_00_1e.2>
module: 5
properties:
    alsa.resolution_bits = "16"
    device.api = "alsa"
    device.class = "sound"
    alsa.class = "generic"
    alsa.subclass = "generic-mix"
    alsa.name = "Intel ICH7"
    alsa.id = "Intel ICH"
    alsa.subdevice = "0"
    alsa.subdevice_name = "subdevice #0"
    alsa.device = "0"
    alsa.card = "0"
    alsa.card_name = "Intel ICH7"
    alsa.long_card_name = "Intel ICH7 with AD1888 at irq 22"
    alsa.driver_name = "snd_intel8x0"
    device.bus_path = "pci-0000:00:1e.2"
    sysfs.path = "/devices/pci0000:00/0000:00:1e.2/sound/card0"
    device.bus = "pci"
    device.vendor.id = "8086"
    device.vendor.name = "Intel Corporation"
    device.product.name = "82801G (ICH7 Family) AC'97 Audio Controller"
    device.form_factor = "internal"
    device.string = "front:0"
    device.buffering.buffer_size = "65536"
    device.buffering.fragment_size = "65536"
    device.access_mode = "mmap+timer"
    device.profile.name = "analog-stereo"
    device.profile.description = "Analog Stereo"
    device.description = "Built-in Audio Analog Stereo"
    alsa.mixer_name = "Analog Devices AD1888"
    alsa.components = "AC97a:41445368"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
ports:
    analog-input-microphone;input-microphone-1: Microphone / Microphone 1 (priority 8720, available: unknown)
        properties:

    analog-input-microphone;input-microphone-2: Microphone / Microphone 2 (priority 8719, available: unknown)
        properties:

    analog-input-linein: Line In (priority 8100, available: unknown)
        properties:

    analog-input: Analog Input (priority 8000, available: unknown)
        properties:

    analog-input-video: Video (priority 7000, available: unknown)
        properties:

active port: <analog-input-linein>



 lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller#1  (rev 01)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller#2 (rev 01)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller#3 (rev 01)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller(rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller (rev 01)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express (rev 21)

Please help me.

share|improve this question

1 Answer 1

The source port of your audio card ist set to <analog-input-linein> which is the Line-In port, not the microphone port.

To change the input port of an audio card we may issue the following command:

pacmd set-source-port <sink-index> <port-name>

In you case this would e.g. be

pacmd set-source-port 2 'analog-input-microphone;input-microphone-1'

We then will also have to make sure that this sink is our default input sink with:

pacmd set-default-source 2

Depending on your hardware me may have to plug-in a microphone first to make this port available.

Note that when running pulseaudio in a per user setting (which is recommended and the default way we do) we do not need to be root to issue the commands above.

share|improve this answer
    
This command is not working After giving command status is active port: <analog-input-microphone;input-microphone-1> Note: You given pcmd command. This command is not found,after that i given pacmd set-default-source 2 –  avamir Jul 20 '12 at 11:58
    
ty - edited this typo, sorry. In case you plug in your MIC to port 2 you'll need to adapt the commands, of course. –  Takkat Jul 20 '12 at 12:04
    
still my mic is not working, you any more information.I have checked with different mic also.Please guide me. Thanks you –  avamir Jul 21 '12 at 6:45
    
it's working now. Thanks Takkat –  avamir Jul 30 '12 at 5:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.