Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Mobile broadband (Tata photon network )is detected and shows in the connections system tray but it does not connect to the Internet.

share|improve this question
    
did you create a new connection for tata photon using network manager? or it is detecting as storage device. –  Web-E Jul 20 '12 at 8:59
    
It is showing as configured in the network connections. But when I try to connect it shows not enabled! :( –  Sowmya Jul 20 '12 at 9:25
    
Yes, I have created a new connection. –  Sowmya Jul 20 '12 at 9:29
    
does Enable mobile broadband has tick mark? its in end of network manager aplet menu –  Web-E Jul 20 '12 at 9:41
    
@Sowmya: Install wvdial using sudo apt-get install wvdial and than follow the instructions given on wvidal archwiki to generate its config file. –  RanRag Jul 20 '12 at 11:08
add comment

1 Answer 1

Use wvdial. Automatic detect USB modem and disable storage.

share|improve this answer
1  
I'm a newbie to Ubuntu.. :( How do I install wvdial now? –  Sowmya Jul 20 '12 at 9:43
2  
Indeed, this answer would be much improved by explaining how to do that. –  Eliah Kagan Jul 20 '12 at 17:27
    
Go TO: en.wikipedia.org/wiki/Wvdial My config: [Dialer Defaults] Init1 = ATZ Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 Modem Type = Analog Modem ISDN = 0 New PPPD = yes Phone = *99***1# Modem = /dev/ttyUSB0 Username = wap Password = wap Baud = 115200 Init3 = AT+CGDCONT=1,"IP","internet.t-mobile.cz" My use: Run - xterm - sudo wvdial My modem is connected ... :) –  Pentium Jul 21 '12 at 8:29
    
If you want to automatically connect when you turn on .. works even when disconnec/connec USB 3G modem. Create your script in the directory /script gsm.sh or script of your choice .. chmod 777 /script/gsm.sh gsm.sh contains #! /bin/bash ( while : ; do wvdial sleep 60 done ) & Now put the whole script in / etc / rc.local /script/gsm.sh exit 0 –  Pentium Jul 21 '12 at 11:30
    
While I'm running: wvdial /etc/wvdial.conf and I get a message saying "Sorry no modem was detected.!" whilst modem is connected. –  Sowmya Jul 23 '12 at 9:10
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.