Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Ubuntu 12.04 in my new machine (with motherboard Asus M5A97, AMD64 3.1GHz) and after the intro menu I select install (or run without install) and I only get a black screen after that. I think it's related to the UEFI boot mode but I am not sure. I tried to install Ubuntu 11 as well and a get a similar problem (although it starts to show some install information but then it stops again). I have also tried Scientific Linux. No success.

When I installed Windows 7 .. had no problems.

Any ideas?

share|improve this question
    
You can try to force the installer to run in BIOS (ie, non-UEFI) mode by removing the file /EFI/boot/bootx64.efi from the USB installer filesystem. There may also be an option in your BIOS configuration screen to disable UEFI boot. –  Jeremy Kerr Jul 20 '12 at 6:29

2 Answers 2

Excuse my english, please. I got same problem installing ubuntu 12.04 in my laptop. I noted the problem have to be something relationed with the wifi hardware because the driver is not implemented in the kernel, I guess. I solved it turning off the wifi (or unplugging it), and getting a normal installation, installing the wifi driver after that. Maybe your problem with another part of your hardware.

share|improve this answer

It shouldn't be an UEFI problem since the Live CD already booted. However, this motherboard uses the typical Asus UEFI, which allows you to boot Live CDs in both UEFI and BIOS mode via the F8/F12 boot menu, given that you use UEFI capable Live CDs like 11.10 amd64 and onward. If you can't install via Live CD, please try the alternate installer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.