Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems starting Psychonauts, from the latest Humble Indie Bundle. Every time I try to start it, the Launcher icon flashes a bit, and then nothing. Here's the output I'm getting:

STUBBED: fix up the rest of the SSE code first at DetectSSESupport (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/MathGeneral.cpp:32)
STUBBED: write me? at SetPCLanguage (/home/icculus/projects/psychonauts/Source/game/luatest/UnixMain.cpp:120)
STUBBED: fix up the rest of the SSE code first at DetectCPUCaps (/home/icculus/projects/psychonauts/Source/game/luatest/Game/PCGameApp.cpp:223)
STUBBED: check LANG envr var at _GetDefaultGameLanguage (/home/icculus/projects/psychonauts/Source/game/luatest/Game/GameApp.cpp:171)
Console created
Save  path: /home/duffy/.local/share/Psychonauts
Write path: WorkResource
STUBBED: inline asm at SSEMul_4x4_4x4_2arg (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/Matrix.cpp:710)
STUBBED: inline asm at SSEMul_4x4_4x4_3arg (/home/icculus/projects/psychonauts/Source/CommonLibs/DFMath/Matrix.cpp:698)
******** unit test failed ********
Transport started
DaveD: NCListenSocket: Listening on port 40001
STUBBED: VK_* at InitInputNames (/home/icculus/projects/psychonauts/Source/CommonLibs/DirectX/SDLInput.cpp:1225)
No joysticks detected
SDL_SetVideoMode() failed: Couldn't find matching GLX visual
Start Up completed in 0.08 seconds
Segmentation fault (core dumped)

I've installed some patch with a 4 in the version... I can't really remember. It didn't help regardless. And I just tried installing the latest Nvidia drivers for my GeForce 7800 GT (don't laugh). Didn't work.

I've found some similar questions to this on askubuntu, but those solutions didn't seem to work either. Please help?

share|improve this question

2 Answers 2

Two things you can try. These may not work on Nvidia, it works on Intel chips, even if it doesn't work it will not harm anything.

First see if you have the needed libraries for texture compression needed for mesa, the easiest way is to open the Software Center and search for;

libtxc-dxtn-s2tc0

If you have Psychonauts installed on a 64bit system it also needs the i386 version of these libs (note if you installed Psychonauts with the Software Center the i386 version should have been installed but check to make sure).

libtxc-dxtn-s2tc0:i386

If you don't have either version of the above libs, install them and try to launch again.(Note: if you can run Amnesia from the bundle it is likely that the 64bit libs are installed already) If you have them or if after install the launch still fails:

You can try to force the system to advertise S3TC support(this was needed for Intel Chips without the i386 version of the libs installed) by launching via the terminal with:

force_s3tc_enable=true  <path to application launcher>

Forcing the S3TC can cause misbehavior so you will have to try it and see if it will work. If the above command does work you can edit the .desktop file to launch the game with the force enabled by using gedit

sudo gedit /usr/share/applications/psychonauts.desktop

Edit the Exec=line and add force_s3tc_enable=true <plus a space> in front of the launch path it should read something like force_s3tc_enable=true /opt/psychonauts/psychonauts.64bin Note the space between the true and the/opt, further note that this is only an example. I no longer have psychonauts installed as my graphic card was not strong enough to handle it(but I did get it working with the force command) so the actual laucher could not have the .bin64 at the very end, but you should know exactaly what the path is and you only need to paste the force_s3tc_enable=true in front of the path in the Exec= command, just make sure to add the [space] before the path

I used RAOF's answer as my source for the commands, I only tried to make it specific to you question, so if this works please make sure to upvote his answer to give him some credit for the original info.

As I noted above I no longer have Psychonauts installed so I can no longer compare the errors that you are getting to the ones that I was.
{EDIT} I have tried installing via the Software Center. I was able to get it to launch without any problems as the .deb file for the i386 version of the libs were downloaded as a dependency. I have edited my answer above to reflect this as well. My graphics chip was still not strong enough to handle the game but I was getting much better performance than when I had to force S3TC performance. With both the 64 & 32 bit libs installed the "force" part of my answer my be unneeded but I will leave it in place in case it is needed by somebody.{EDIT}

share|improve this answer

I just experienced the same issue. The Psychonauts desktop shortcut is set to launch psychonauts.sh by default. It seems the Bash file is trying to do some clever workaround mostly for Intel graphics cards (incl. integrated graphics). Unfortunately this interferes with the NVidia drivers and causes a segmentation fault. In my case I was able to run the game by using /opt/psychonauts/Psychonauts directly (note capital P and no .sh). I am also running Bumblebee so in my case the full command is:

$ optirun /opt/psychonauts/Psychonauts

If this doesn't work for you, try updating the LD_LIBRARY_PATH environment variable so it points to the NVidia driver's files like so:

$ LD_LIBRARY_PATH=/usr/lib32/nvidia-current [optirun] /opt/psychonauts/Psychonauts

optirun is optional and you should include it only if running on an Optimus configuration with a discrete video card.


If you wish to learn more about the variables included in the Bash file, here are a couple of articles of interest:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.