Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having problems with my Pulse Audio server, and recently while investigating, I came across these error messages in /var/log/syslog:

Jul 20 09:16:40 mythbuntu pulseaudio[6555]: [pulseaudio] module.c: module-combine is deprecated: Please use module-combine-sink instead of module-combine!
Jul 20 09:16:40 mythbuntu pulseaudio[6555]: [pulseaudio] module-combine.c: We will now load module-combine-sink. Please make sure to remove module-combine from your configuration.

I looked in /etc/pulse/default.pa for any mention of module-combine, but did not see any. Also, I searched the web for elements of the error message and only got links to bug reports with vague discussions.

How do I get rid of this module-combine error?

share|improve this question
    
If you could not find module-combine did you add load-module module-combine-sink to your /etc/pulse/default.pa –  damien Jul 20 '12 at 3:39
    
@damien: Thank you for responding. load-module module-combine-sink is not in /etc/pulse/default.pa. If I add it, can I add it to anywhere in the file? Or does it need to be at the end of the beginning...? –  Dave M G Jul 20 '12 at 4:17
    
just place it down the end of the file.save and restart to take affect –  damien Jul 20 '12 at 4:31
    
@damien: Thanks. I did that, but I still get the same please make sure to remove module-combine error. Also, I now get a new error: [pulseaudio] module-zeroconf-publish.c: avahi_entry_group_add_service_strlst(): Local name collision –  Dave M G Jul 20 '12 at 4:35
    
For now perhaps undo the changes and ill look into it a bit further for you –  damien Jul 20 '12 at 4:52
show 2 more comments

3 Answers 3

up vote 3 down vote accepted

The issue is in the 'paprefs' package, which on the 'Simultaneous Output' tab controls loading the 'module-combine' module. It has not been updated to use the 'module-combine-sink', and the 'module-combine' is now a dummy module that simply warns and then loads the 'module-combine-sink'.

You can change the module loaded by the paprefs setting by using 'gconf-editor' and changing 'system/pulseaudio/modules/combine', the 'name0' key should have 'module-combine-sink' value instead of just 'module-combine'.

In theory there are two bugs:

  1. 'paprefs' shouldn't be using 'module-combine'
  2. 'paprefs' should migrate to 'dconf'

Hope that helps.

share|improve this answer
add comment

From the pulseaudio warning we can see that some script or application tries to load the deprecated module-combine. This however will not do any harm to your pulseaudio setup as pulseaudio has a fallback mechanism to load the module-combine-sink instead. Of course this will not be done without a warning in the logfiles.

If you really want to get rid of this message you will have to investigate places where this module may be loaded. One possibility is your /etc/pulse/default.pa which could also be located in ~/.pulse/default.pa. Another possibility is /etc/pulse/system.pa in case we run pulseaudio system-wide, or an older version of paprefs.

However any application may load a pulseaudio module at runtime. We have no experience on Mythubuntu, and have no idea which applications you may have installed. It may be therefore be worth to check what application have just started when the warning message appears, and see if any of those have a configuration file where we need to replace the module-combine by module-combine-sink.

share|improve this answer
add comment

I used the gconf-editor to change the name of the module, and pulseaudio immediately failed and could not be started; I added the load line into the default.pa, the daemon would not load; I also tried embedding the load line in the .if bracketing lines as with the other modules, and I confirmed that I did have module-combine-sink.so and that it was a compatible ELF 32 shared library file.

but if I have the module enabled in gconf-edit, the daemon will not load, and if I disable it, the daemon will load, but of course without the combined channel pseudo device.

this is new behaviour since upgrading to 12.10.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.