Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using webapp integration and I accidentally clicked "No" when asked if I want to integrate with the website.

How can I have Firefox or Chrome reask me to integrate the site with Ubuntu?

share|improve this question

5 Answers 5

Chromium now gives the user the opportunity to have a finer amount of control over the revocation of previous decisions such as the one showed above.

(Using the latest chromium provided in the package)

Go to "chrome://settings", then open the advanced settings section where there should be a "Desktop Integration" section with a checked checkbox ("Allow integration"), and a button. Click on the button and the websites for which you previously made a decision are listed. Removing any site from the list will re-trigger the integration step,

See:

Desktop integration settings in Chromium

share|improve this answer
1  
Note that Firefox offers the same functionality through the "General" section (at the bottom of it) of the preferences panel, –  Alex Abreu Aug 7 '12 at 15:24
    
+1.. Pictures and screenshots would be very much appreciated! –  jokerdino Aug 7 '12 at 15:28
    
Image of desktop integration added –  Alex Abreu Aug 7 '12 at 19:19
    
It works for me on Chromium, but not on Firefox. The list of sites appears empty there. Looking at dconf editor (com.canonical.unity.webapps) , allowed-domains contains a list of the site s I've already made a decision for and dontask-domains is empty there. –  David Planella Aug 12 '12 at 15:43
1  
Help! I don't have this "Desktop Integration" section. I have the webapps extension installed and enabled –  G1i1ch Jan 15 '13 at 10:22
  1. On Firefox, go to Edit > Preferences > General tab.
  2. There you'll see a Desktop integration header. Click on the Exceptions... button Preferences
  3. Use the - button to remove all the website entries you'd like to be re-prompted to integrate with.
  4. Click Close

That's it :)

share|improve this answer
1  
Not there in Ubuntu 12.04. –  saji89 Jan 17 '13 at 7:05
    
@saji89 Webapps were only a technical preview on Ubuntu 12.04 and are not fully supported there. For full webapps support, Ubuntu 12.10 is required. –  David Planella Jan 17 '13 at 10:03
    
What if it's not there and you're on 14.04? –  FuzzyToothpaste Sep 7 at 21:27
up vote 12 down vote accepted

There is currently no UI for this but there is a workaround. First install dconf-tools Install dconf-tools and then run dconf-editor

Then navigate to com.canonical.unity.webapps

enter image description here

And adjust the domains allowed. To reset them all you can do this command:

gsettings reset com.canonical.unity.webapps allowed-domains

Or you can also press the 'Set to Default' button

share|improve this answer
    
This answer is if you accidentally clicked "Yes", I guess. If you accidentally clicked "No", just remove from "dontask-domains", or use the Firefox UI as explained by Bruno Pereira. –  Nicolas Raoul Jun 12 '13 at 8:11
    
This is no longer the best answer. There is a UI in Firefox now. –  Eric Lambart Jun 24 at 3:10

Edit > Preferences > General.

Make sure that the Prompt integration options from any website is checked and click on the Exceptions button. From the websites list there choose the website you want to integrate and press the - button and close the dialog box and the preferences window

enter image description here

Reload the web page or visit the site again and you should be asked if you want to integrate the website features on your desktop again.

share|improve this answer
    
There is no such option longer availabe in Ubuntu 14.04 –  Ed Villegas May 3 at 14:57

How to re-prompt promp for webapp to launch, unity-webapp-gmail run reinstall (tags for search engines :

In chrome -> chrome://chrome/settings/ -> advanced settings(check) -> installed websites -> Notify me when the website I am visiting can run as an application.

settings

OR

If you've already disabled the app try looking at exceptions.
Later on you may want to click the icon which is located in URL bar left to bookmark star icon.

URL bar

share|improve this answer
    
the second part of the answer is exactly what i was looking for, thank you! most of the other answers are outdated or simply don't work in chrome (v28) –  amc Aug 8 '13 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.