Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried updating my packages from the terminal and this is what I got:

$ sudo apt-get update
E: The method driver /usr/lib/apt/methods/http could not be found.
E: The method driver /usr/lib/apt/methods/http could not be found.
E: The method driver /usr/lib/apt/methods/http could not be found.
E: The method driver /usr/lib/apt/methods/http could not be found.
E: The method driver /usr/lib/apt/methods/http could not be found.

What does this mean? I'm using the United States mirror an I've tried using the main server for the mirror and I keep getting the same result is this because there are no updates?

share|improve this question
    
Can you show your /etc/apt/sources.list? – César Jul 19 '12 at 20:28

SirCharlo said in the duplicate of this question:

sudo apt-get install apt-transport-https

I tried it and it worked for me.

share|improve this answer
    
This worked for me in Debian Squeeze. – Matt Alexander Dec 12 '12 at 22:27
    
How is this possible? He can't able to connect to the internet. – Avinash Raj Apr 12 '14 at 12:16

Probably in your /etc/apt/sources.list there is http//: instead of http://. Check this file.

share|improve this answer
    
It says i dont have permission? – Abe Jul 20 '12 at 3:40
    
from terminal use: sudo gedit /etc/apt/sources.list or sudo nano /etc/apt/sources.list. It will ask you your password. – Victor K Jul 20 '12 at 5:31
    
Ok now i have access to the file but there nothing wrong with it the http:// is in the right protocol. theres no quotes around anything everything seems pretty much in place – Abe Jul 20 '12 at 14:11
    
Why don't you update your question and show your sources.list or at least give the link to a pastebin.com or something – César Jul 20 '12 at 14:18
    
(pastebin.com/yuB25JPx) – Abe Jul 20 '12 at 14:28

I have faced this problem before, in my case the problem was in /etc/apt/sources.list. Make sure there are no quotation marks '' or "":

deb "http://archive.canonical.com/ubuntu/ maverick partner (Source Code)"

Remove quotes and change those lines to:

deb http://archive.canonical.com/ubuntu/ maverick partner (Source Code)

Also, as @arhimed suggests, make sure the protocol is well-formed: http://

share|improve this answer
    
Everything is in good form any other ideas? – Abe Jul 20 '12 at 14:12

in my case, find all the source in .list file, eg:

/etc/apt/sources.list 
/etc/apt/sources.list.d/nginx.list 
/etc/apt/sources.list.d/passenger.list

some source in the list are forced using https:// even if you changed it into http:// it will redirected to https://

the solutions is :

  1. backup and remove the https source first
  2. then run apt-get update
  3. run sudo apt-get install apt-transport-https
  4. restore the https source
share|improve this answer

I have resolved it just now by this command:

cd /etc/apt ; sudo rm sources.list ; mv sources.list~ sources.list
share|improve this answer
4  
Please don't blindly do this! This will restore the old config file from backup, but that won't work for you unless you have a working backup saved in that spot! – Nate C-K Aug 29 '14 at 13:53

My error read method driver /usr/lib/apt/methods/htttp and after reading here and trying all offerings, I was about to give up when I noticed that the http had one extra t.

I went to did this:

sudo -H gedit /etc/apt/source.list

Ctrl + F to find all instances of htttp.

removed the extra t

Saved (twice to make sure the bugger took it)

And viola, problem solved.

Guess that means I need to REALLY Read the error messages as I had been skimming over them. Lesson learned. that won't happen again

share|improve this answer

look for https links in /etc/apt/sources.list check if http link of the same link works. if it does then replace http with https and enjoy. otherwise install sudo apt-get install apt-transport-https as said in the above answer by Damiön la Bagh

share|improve this answer

My comments here aren't directly related to the OP's question, but since this page comes up in google's first result when searching E: The method driver /usr/lib/apt/methods/https could not be found. which is the error I was originally trying to solve, I am adding some information which helped me solve my problem.

I happen to be on an ethernet network which contains a "firewall" type device that redirects an unknown computer's web traffic to a webpage that requires you the "agree" to the terms of service for the network before you can continue. This page happens to be served as a HTTPS page. Therefore, any time apt-get tried to connect, it was ending up at an HTTPS site. This is also why trying to install apt-transport-https wasn't working for me.

share|improve this answer
    
That's called a captive portal. – muru May 15 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.