Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After creating a vhd and going through that process i'm unable to install win7 x64. I've went through various settings and trying to get it right. It'll boot the windows install but then indicate the following error (image included too):

A required cd/dvd drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.

Note if the windows installation media is in the CD/DVD drive, you can safely remove it for this step.

enter image description here

I've also set up my storage tree like so:

enter image description here

Would anyone know what the issue could be? It's asking for cd/dvd device drivers and i'm unable to install.

share|improve this question
    
You probably have a scratched Windows CD or a broken CD drive. That message pops up when also when the setup cannot read a file from the CD you are using. –  Bruno Pereira Jul 19 '12 at 19:19
    
Are you installing fro CD, or an ISO? –  Mitch Jul 19 '12 at 19:21
    
From CD. I was able to install from cd before too on different machines this is the first time i've had this issue. –  chrisjlee Jul 19 '12 at 19:27
    
as I can not answer on this topic (due to too less rep points): For me it turned out that my downloaded ISO (from dreamspark) was currupted! A fresh new download solved all my problems –  Jan1337z Mar 5 at 15:02
    
Seems like corruption was the culprit for me too. I tried another disk and it worked fine. –  trusktr Jun 11 at 20:11
add comment

3 Answers 3

up vote 14 down vote accepted

I ran into this problem today, you probably already solved your problem, but I'm just adding my experience as it may help somebody else.

(I used a physical install CD and not an ISO file)

  1. Open your VM settings
  2. Go to Storage
  3. Select the CD-ROM drive
  4. Check Passthrough
  5. Boot the VM with the Windows

This solved it for me, so it might be worth a shot.

share|improve this answer
    
I don't see any such option. Using VirtualBox 4.3.10 on ubuntu –  Jonathan Apr 24 at 20:36
    
That's odd I'm using VB 4.3.10 on ubuntu trusty and I can see the checkbox. It fixed the problem for me as well. –  Tom Jun 11 at 16:35
add comment

This is just a wild guess.

It can be complaining because some of the virtualiced hardware is not compatible out-of-the-box with Windows 7. The most likely problem is the network card, if it was another componente Windows will just connect to internet to try to download the driver.

Can you try to change your emulated NIC model in the Network section of the Virtual Machine configuration?

share|improve this answer
    
That's a good point. It's worth a shot. Thanks –  chrisjlee Jul 20 '12 at 15:06
add comment

You can set a passthrough but this is also where you can point to an ISO file of your disc. I used an ISO because it makes the OS install much much faster and passthrough gets a lot of hiccups for long read times. Think of it as playing hot potato with 3 people instead of just 2.

share|improve this answer
add comment

protected by Community Jul 9 '13 at 21:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.