Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Nautilus used to be lightning fast.Now it's dead slow.

I have tried upgrading the video card but that does not seem to be the problem.

Also I found that there was a problem with the Dropbox uninstall, finally I replace it with pcmanfm which appears to be much faster but the down side is that I no longer have the gwibber social client and a lot of stuff don't work like they use to.

Also I completely removed nautilus and couldn't even login to ubuntu to install again nautilus.How can I remove or repair nautilus, and use pcmanfm instead?

I have a dell inspiron 1440 3gb ram / disk 300gb /

Additionally, why does nautilus run fast when I run it as root? There are no USB devices attached to my computer.

Thanks in advance

share|improve this question
    
If you remove Nautilus you're taking much of the Gnome Desktop with it, just leave it there, and keep PcmanFM and replace it as the default file manager. –  Uri Herrera Jul 19 '12 at 17:26
    
If Nautilus is slow, there is probably something that is causing it to be slow besides the normal filesystem, such as some device or something like the gwibber social client. If you like Nautilus better than pcmanfm, why not try to find out what is making it slow? You could try running top (or better yet, htop) to see if something is using a lot of CPU. I don't use gwibber - can it be temporarily disabled? Any devices like USB, etc that can be disconnected? Any other changes that may have caused it to become slow? –  Marty Fried Jul 19 '12 at 17:41
    
if i run nautilus a root runs lightning fast/ why is that? –  david Jul 19 '12 at 17:47
    
Something's wrong with your config. files then. –  Uri Herrera Jul 19 '12 at 17:49
    
what do you recommend? replace config files erase them and i will auto create them? not sure about this! –  david Jul 19 '12 at 17:57
show 1 more comment

4 Answers 4

I think you sould might install PCManFM (File Manager like Nautilus), it's the default file manager on Lubuntu, it's is "lightning fast" and it's interface looks like Nautilus.

You can install it from the Terminal with:

$ sudo apt-get install pcmanfm
share|improve this answer
1  
wow great thanks –  Poovizhirajan.N Sep 13 '13 at 9:02
1  
pcmanfm is awesome –  Yousuf Memon Jan 26 at 14:55
    
It working like a black jaguar which running on the plain. –  pylover Jan 31 at 1:22
add comment

I had this problem too. For me I solved it by removing a symbolic link on the root directory which pointed to a network mount (smbfs) that wasn't reachable at the time. It also caused other gnome applications like gedit (gnome-text-editor) to become very slow.

I guess you would have the same problem if you have an unreachable network mount directly below the root. You should see the same lag if you simply do a 'ls /' in a terminal window. Apparently some apps That triggered me to find the solution.

Removing the symbolic link solved it for me.

share|improve this answer
    
How do you find out whether you have such a symbolic link which one should remove? –  Rasmus Nov 6 '12 at 19:15
    
No, the nautilus is really slow, it has more problems. –  pylover Jan 31 at 1:28
add comment

You may try to launch nautilus from terminal, and if you would see the fallowing samba error: "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory Please ask your system administrator to enable user sharing." Then you could just remove the ../usershare and nautilus should speed up.

share|improve this answer
    
What do you mean when you say to "remove the ../usershare"? –  Eliah Kagan Mar 11 '13 at 11:08
    
/var/lib/samba/usershares –  Reza Saidafkan Mar 13 '13 at 22:46
add comment

I had a similar problem - not sure about what "slow" you are talking here, but my slow was about nautilus slow start up and annoying rotating (busy) cursor when switching directories.

Solution: try running nautilus from terminal command line - just like

you@yourhost$ nautilus

if this brings the joy back in form of nautilus without lag then just edit the link/shortcut/launcher properties by changing field

Command: "nautilus %U" into just "nautilus" without fancy %U

worked for me. Hope it will help u2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.