Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using the proprietary nVidia CUDA developer's drivers on my Ubuntu 12.04 Gnome 3 shell, from here: http://developer.download.nvidia.com/compute/cuda/4_2/rel/drivers/devdriver_4.2_linux_64_295.41.run

Everything works well until I perform an update to the system (via the update manager). Whenever something (I think xorg server) gets an update, the gnome shell boots only to 'Classic Mode'. Booting to recovery console and reinstalling the proprietary drivers solves the problem.

Is there any way to tell the update manager to never update/overrun the devdrivers?

It's really a pain having to reinstall the drivers every time I update the system.

share|improve this question
add comment

1 Answer

Well, really only every time you update the kernel, so either turn off kernel updates (purge the package linux-generic-pae) or add in your install script to /etc/kernel-img.conf which runs when the kernel updates. Really though, how much trouble are you going to go to to avoud a "make install".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.