Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used gksudo nautilus (not through the terminal but through the 'Open With' command) for some copy & paste stuff that requires root access.

But now whenever I open the file browser (Nautilus) to access my local folder, it doesn't open normally, but opens with root access as if I had used gksudo nautilus again.

Only Trash is able be to opened normally without any root access.

How can I get back the normal, unprivileged behavior for nautilus?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Go to the /home/user/.local/share/applications/ directory, in there is you users custom mime settings. One or more files will be called userapp-SOMETHING.desktop just delete the one causing problems - you can examine which one you need to delete by opening them with gedit.

You might have to re-login for changes to take affect but I don't think so.

share|improve this answer

In general it might be a good idea to install nautilus-gksu. This package allows you to switch to root. It adds a menu entry where you can choose to work with root access.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.