Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 about two weeks ago and everything booted fine and dandy. About four days ago I booted my laptop and instead of the usual it came up with this:

http://imageshack.us/photo/my-images/834/img0076sd.jpg/

enter image description here

I installed Ubuntu after Windows 8 caused havoc with my machine (no physical damage) and as such I installed Ubuntu on it's own (no Wubi). Selecting any of the options seems to do nothing (the first option just leaves me with a blinking cursor).

I'm not someone who's competent with coding so any help would be appreciated :)

share|improve this question
1  
Have you tried selecting the Previous versions option –  atenz Jul 19 '12 at 15:12

1 Answer 1

Try Boot Repair.

1 - Live CD

First, you'll need to boot from a Ubuntu Live CD.

2 - Repair the bootloader

To repair and restore the Grub bootloader, follow these steps.

Open a terminal from the Live CD, and run the following commands:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair
boot-repair

After a few seconds, Boot Repair's main window will open.

Click on Recommended repair.

You're done!

Reboot to test everything out.

If everything went well, you should be up and running now.

share|improve this answer
1  
Worked like a charm, thank you :D –  John Jul 19 '12 at 16:57
    
@John No problem! Please mark the answer as accepted, to prevent it from showing up in the Unanswered section. Thank you! :) –  SirCharlo Jul 20 '12 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.