Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HTPC with a ASUS P7H57D-V EVO motherboard and an i5 processor/GPU. I am using HDMI audio out to a Panasonic TV. HTPC is running Ubuntu 12.04 LTS with MythTV 0.25. In most applications I get an intermittent, metallic buzz noise every 10 to 12 seconds. The noise lasts for a second or less each occurrence.

The noise is audible through any application except MythTV. As a result, I'm confident it isn't a physical problem or any particular media file (the same mp3 will sound fine when played with MythTV, but will buzz with Rhythmbox).

I've spent a lot of time playing around with my .asoundrc file (some reading suggested a resampling issue) and a few snd-hda-intel models.

After having spent hours on this issue, I am hoping someone who knows more about alsa and HDMI can tell me if I'm at least on the right path or if I should be looking somewhere else for the resolution. Honestly, I'd be happy if I could just get Hulu Desktop to stop making the noise (in addition to MythTV). For instance, since I launch Hulu Desktop from MythTV, can it somehow inherit MythTV's audio settings?

Thanks for your time!

share|improve this question

1 Answer 1

Although I am not yet running Ubuntu, I just had a similar problem with HDMI audio (analog audio worked fine) on my system (F17/KDE, Asus P8Z77-V, i5 CPU with HD4000 graphics, Panasonic TV), so I wish to share my findings:

Googling the problem bought me here, prompting to install mythtv (0.25.2). There at the advanced audio settings forcing the audio device (set to ALSA:hdmi...) to output 48 kHz made the buzzing go away as regards mythtv - probably similar to what you experienced.

As I have pulseaudio installed, the solution - at least for mplayer, vlc and mythtv - was to set the default sampling rate to 48 kHz in /etc/pulse/daemon.conf (I do not have a PA config file in my home directory).


Before that I did some experimenting with ALSA and mplayer addressing the HDMI device without PA (suspending PA with the command pacmd and entering suspend 1): the problem persisted until I used the option -srate 48000 in mplayer (with PA active -srate did not help as the default sampling rate for PA is 44100 Hz).

In my case I did not need to set the (re-)sampling rate for ALSA, but if you still want to experiment with it, please bear in mind that an active PA can have an influence on the final sampling rate at your sound device. This rate you can see by checking out /proc/asound/cardX/pcmXp/subX/hw_params while playing audio (for me cat /proc/asound/card0/pcm7p/sub0/hw_params worked).

share|improve this answer
    
2 years late on my part, but I would like to mark this answer as correct. Thank you for the answer. I rebuilt my machine recently and the problem came back. A quick google search brought me back to this page and solved it for me again. Also, if you are using XBMC, this can be set in the advancedsettings.xml file. <audio><resample>48000</resample></audio>. Thanks again for the help... twice! –  Ian Feb 20 at 1:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.