Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have three Linux and two windows systems on one computer.

After updating the kernel on one (archlinux) and running update-grub on the default (BIOS) boot disk (Xubuntu 12.04), the boot menu does not report the archlinux system.

After running boot-repair, I cannot boot the archlinux system by selecting it as the boot disk in BIOS because it now uses the boot configuration on the Xubuntu system instead of booting directly from its disk.

I really need to be able to boot the archlinux system, how can I do this?

Note: Bugs filed and notices made on this.

share|improve this question

3 Answers 3

Try this:

sudo nano /etc/grub.d/09_custom_arch

Put the following text in the file:

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Arch Linux" {
insmod ext2
set root=(hd0,1)
linux /vmlinuz26  root=/dev/sda2 ro quiet rootdelay=1
initrd /kernel26.img
}

Be sure to modify the (hd0,1) and sda2 to reflect the actual partition that contains Arch Linux in your particular setup.

Now, run:

sudo update-grub

This should at the very least steer you in the correct direction.

Credits

share|improve this answer
    
This looks like a good work-around, but I cannot get it to work or find any documentation that I can use. One of the problem is that the disk is sometime sda and other times is sdg. I'm going to ask another question. (I wish I had backed up the grub.cfg from when it did work :( ) –  keepitsimpleengineer Jul 19 '12 at 21:04
    
Although this will probably work for others, it doesn't on my hardware because the BIOS mixes up the hard-drive order from boot to boot. :( –  keepitsimpleengineer Jul 20 '12 at 18:50
up vote 0 down vote accepted

The 10.04 Ubuntu and the 12.04 Xubuntu grub2 failed for different reasons, so I used the third Linux system to solve the problem, see os-prober fails to identify a linux system so I need to write a custom grub2 menu entry as a workaround, how?enter link description here for details.

share|improve this answer

Try it with Super GRUB 2 disk.

You can download it from here

Then install it in a usb using Unetbootin Now you could restart your system and make sure it is set in the boot option menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.