Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed a MaaS node that will act as the parent and I am trying to add additional nodes via the PXE boot. The nodes boot fine and get an image from the MaaS server but they only install the 32-bit version. They are 64-bit machines and I would really like them to use the 64-bit version of Ubuntu Precise. The MaaS server has the precise_x86_64 image according to the maas-import-isos and it is an option when its doing a network boot.

However if I do the maas-precise-x86_64 the node doesn't register with the MaaS parent node. It seems like it just installs a clean version of Ubuntu 12.04 64-bit.

What I want to know is if there is a setting I have to change or something to get it to just boot over network and use the 64 bit instead of the 32-bit version?

I have checked everywhere for this answer and couldn't find anyone even referring to the other options at network boot. Everyone just wants you to wait for the timeout but for me that means it'll install the i386 version instead of the x86_64.

Has anyone experienced this and knows how to make it install with the 64-bit version instead of the 32-bit one?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

As discussed on IRC. The reason a 64bit client is not being installed in this particular case, is because the installation process that seems to be using i386 is not really an installation process.

What's happening here is that the client Machine is trying to enlist itself into 'MAAS', and it uses a i386 image. Once the machine is enlisted, you will be able to 'Accept&Commission' the machine from the WebUI. Once the machine is commissioned, then it will become 'Ready' for deployment.

Once you deploy it will install Ubuntu 64bit.

share|improve this answer
    
thanks I appreciate your help I'm working on deploying them now in this manner. –  Eric Jul 19 '12 at 15:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.