Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a second hard drive that I've installed on my system, and copying files from the USB to the hard drive is extremely slow (about 70kB/sec).

Here is my /etc/fstab entry:

/dev/sdb1 /media/Storage ntfs uid=rhys,gid=users,auto,user,exec,rw,sync 0 0

Am I doing something wrong here?

share|improve this question
    
Are you using usb 1.0 or usb2.0? –  Prasad RD Jul 19 '12 at 13:49
    
I've tried the USB 2.0 and 3.0 ports. –  12hys Jul 19 '12 at 13:59
1  
Are you copying several tiny files, or rather big ones? –  SirCharlo Jul 19 '12 at 14:11
    
I'm copying big files. –  12hys Jul 19 '12 at 14:32
add comment

2 Answers

Actually, asyncronous copy shouldn't change the speed. It would look like that because the copy happens in background, but you won't be able to unmount the drive any sooner than before. At least with syncronous tranfer when it says "Done", it really is done... but the downside is that the pop-up "Copying" box will hang around for ages.

share|improve this answer
add comment
up vote 1 down vote accepted

Seems as though switching the flag from sync to async fixes the issue.

/dev/sdb1 /media/Storage ntfs uid=rhys,gid=users,auto,user,exec,rw,async 0 0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.