Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When writing to my ntfs partition I am getting very low speeds( When reading however I'm getting my maximum speeds):

589824   3%   60.20kB/s    0:04:06

This example is using

rsync --progress [File] [Destination]

Where I am making a copy of the file in the same directory.

I am mounting my ntfs partition using fstab:

/dev/sda6 /mnt/data ntfs-3guid=1000,gid=11000,umask=0022,sync,auto,nosuid,rw,nouser 0 0

I am not sure if this is relevant but I was recently looking at the Power Tweaking tips provided on the Ubuntu wiki and I believe that these situations may correlate.

Grub Conf:

GRUB_BACKGROUND=/boot/grub/gbackground.jpg
GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=0

The power tweak that I believe is causing the problem is the ALPM.

Note: My write speeds to my ntfs patition were absolutely fine until about yesterday when I started fiddling with the power tweak(s)

I am using one drive with multiple partitions, so it cannot be a hardware error, this is also because My dual boot in windows can access the drive at normal speeds.

share|improve this question

2 Answers 2

It's the sync option that you show in your fstab line that's doing it. This is a common problem when using an external USB drive that uses usbmount. From /etc/usbmount/usbmount.conf:

#############################################################################
# WARNING!                                                                  #
#                                                                           #
# The "sync" option may not be a good choice to use with flash drives, as   #
# it forces a greater amount of writing operating on the drive. This makes  #
# the writing speed considerably lower and also leads to a faster wear out  #
# of the disk.                                                              #
#                                                                           #
# If you omit it, don't forget to use the command "sync" to synchronize the #
# data on your disk before removing the drive or you may experience data    #
# loss.                                                                     #
#                                                                           #
# It is highly recommended that you use the pumount command (as a regular   #
# user) before unplugging the device. It makes calling the "sync" command   #
# and mounting with the sync option unnecessary---this is similar to other  #
# operating system's "safely disconnect the device" option.                 #
#############################################################################

So just remove the sync option from fstab or change it to async. If you are hotplugging change the following line in that /etc/usbmount/usbmount.conf from:

MOUNTOPTIONS="sync,noexec,nodev,noatime,nodiratime"

to

MOUNTOPTIONS="noexec,nodev,noatime,nodiratime"

And don't forget to safely unmount your drive before unplugging.

share|improve this answer

Happened to me once. I had edited the fstab to automount the NTFS partition automatically at boot. Restoring the file to before editing it did the trick.

share|improve this answer
    
Thanks, I actually just gave up and re installed Ubuntu, not sure if I should put that as an answer as it's not really a fix... –  hamhut1066 Aug 16 '12 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.